VxRail : vCenter signale une capacité vSAN incorrecte

Résumé: vCenter signale une capacité vSAN incorrecte

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Lors de la vérification de la capacité vSAN à partir de vSphere Web Client, la capacité VSAN affichée est inférieure à la capacité vSAN attendue. RVC affiche la capacité VSAN correcte.

Dans ce cas, chaque nœud disposait de disques d’une capacité de 3 à 1 To qui totalisaient ~13 To de capacité VSAN totale. Le client Web vSphere a affiché ~9 To, comme indiqué ci-dessous :
Capacité sur vSphere Web Client

De RVC :

/localhost/MARVIN-Datacenter/datastores> ls
1 MARVIN-Virtual-SAN-Datastore-0385aed5-ddae-42f7-aab2-8fe5f992c9b9: 14258.75GB

 

Cause

Un des hôtes du cluster a cru qu’il était toujours en mode maintenance. Il ne s’affichait pas en mode maintenance dans vCenter, mais la sortie ci-dessous indiquait qu’il était en mode maintenance :

À partir de l’hôte esx, exécutez la commande suivante.

cmmds-tool find -f python

Et vérifiez le decomState :

{
   "uuid": "57908981-beff-abdf-f76d-001e67dc4fc0",
   "owner": "57908981-beff-abdf-f76d-001e67dc4fc0",
   "health": "Healthy",
   "revision": "6",
   "type": "NODE_DECOM_STATE",
   "flag": "2",
   "minHostVersion": "0",
   "md5sum": "7c88fc7eea9891e32bc7b35532085ee5",
   "valueLen": "80",
---> looks like we're decommissioned due to Maintenance Mode:
   "content": "{\"decomState\": 6, \"decomJobType\": 1, \"decomJobUuid\": \"00000000-0000-0000-0000-000000000000\", \"progress\": 0, \"affObjList\": [ ], \"errorCode\": 0, \"updateNum\": 0, \"majorVersion\": 2}",
   "errorStr": "(null)"
},

Causes possibles de ce problème :

  1. La destruction d’un groupe de disques sans placer le nœud en mode maintenance peut placer un nœud dans cet état. Cela ne causerait pas ce problème, mais cela peut parfois se produire.
  2. L’échec de la maintenance avec migration complète des données peut en être la cause. En général, ce sont les objets inaccessibles et orphelins qui peuvent provoquer l’échec d’un hôte en mode de maintenance (MM).
  3. La disjonction et la réintégration d’un nœud du cluster VSAN peuvent en être la cause.

 

Résolution

Mettez l’hôte en mode de maintenance (Garantir l’accessibilité), puis quittez le mode de maintenance une fois que l’hôte est en mode de maintenance.
Une fois cette opération effectuée, la capacité VSAN doit s’afficher correctement dans vSphere Web Client.

 

Produits concernés

VxRail Appliance Family

Produits

VxRail Appliance Family
Propriétés de l’article
Numéro d’article: 000052308
Type d’article: Solution
Dernière modification: 17 Apr 2026
Version:  6
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.