NVP vProxy : vSphere Web Client Plugin signale une installation réussie, mais ne s’affiche pas

Résumé: vSphere Web Client Plugin signale une installation réussie, mais ne s’affiche pas

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

L’intégration NetWorker VMware Protection est configurée avec l’appliance vProxy.  Le serveur vCenter est sélectionné, sous VMware View, dans NetWorker Management Console (NMC) pour installer le plug-in vCenter.  Les résultats de l’installation du plug-in vCenter indiquent qu’il est correctement installé, mais le client Web vSphere n’affiche pas le plug-in Dell EMC NetWorker.

Cause

Le plug-in vSphere Web Client a peut-être été installé dans un état incohérent ou les fichiers d’installation précédents du plug-in interfèrent avec la nouvelle installation du plug-in.

Résolution

Supprimez les enregistrements existants du plug-in Dell NetWorker du serveur vCenter.  Les instructions sont également disponibles dans la section « Supprimer le plug-in vCenter flash du client Web vSphere » du Guide d’intégration de Dell EMC NetWorker VMware.  Pour plus de commodité, l’article de la base de connaissances fournit des étapes plus détaillées pour supprimer l’enregistrement du plug-in Dell EMC NetWorker.

1) Connectez-vous au navigateur d’objets gérés (MOB) vCenter à l’aide du compte administrator@vsphere.local. Le MOB est accessible à partir d’un navigateur Web qui peut atteindre le nom d’hôte/l’adresse IP du vCenter : https ://vcenter_name/mob
a) Lorsque vous êtes connecté au MOB, sélectionnez le contenu
b) Dans la fenêtre Service Content, sélectionnez ExtensionManager
c) Dans la fenêtre ExtensionList, sélectionnez plus...
d) Il y aura 3 extensions pour le plug-in netWorker vSphere Web Client. Celles-ci devront être supprimées :
kA2f1000000KA2uCAG_2_0
e) Sous Méthodes, sélectionnez UnregisterExtension
f) Dans la fenêtre UnregisterExtension, saisissez le nom de l’extension et sélectionnez Appeler la méthode :
kA2f1000000KA2uCAG_2_1
Remarque : Lorsque « Method Invocation Result : void » s’affiche, vous pouvez spécifier le plug-in suivant et le supprimer. Répétez cette méthode pour chacun des serveurs com.emc.networker... Plugins.
g) Actualisez la fenêtre MOB ExtensionManager. Les plug-ins com.emc.networker doivent être supprimés de la liste d’extension.

2) Connectez-vous au serveur vCenter via SSH.
a) Le site com.emc.networker.. dir doit être supprimé de la base de données de vCenter Server. 
Linux : /etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity
Remarque : Cet emplacement peut varier en fonction de la version de vCenter. Reportez-vous à la documentation VMware si le plug-in est introuvable dans les chemins d’accès ci-dessus.
Par exemple : 
root@vcenter65 [ ~ ]# ls -l /etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity
total 8
drwxr-xr-x 3 vsphere-client users 4096 Nov  6 17:02 com.emc.networker-9.2.1246
drwxr-xr-x 3 vsphere-client users 4096 Jul  6 17:06 com.vmware.vsan.health-6.5.0

b) Le plug-in peut être supprimé en supprimant le dossier com.emc.networker.
4) Attendez que les services du client Web vSphere aient démarré, vous serez en mesure de vous connecter au client Web vSphere.
5) Connectez-vous à NMC et relancez l’installation du plug-in.
6) Déconnectez-vous du client Web vSphere et reconnectez-vous.
kA2f1000000KA2uCAG_2_2

Produits concernés

NetWorker

Produits

NetWorker
Propriétés de l’article
Numéro d’article: 000166557
Type d’article: Solution
Dernière modification: 30 Apr 2025
Version:  5
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.