NetWorker : Impossible d’installer le logiciel NMC Server sur un NetWorker Server Windows ou un serveur NMC dédié
Résumé: Impossible d’installer ou de mettre à niveau le serveur NetWorker Management Console (NMC) sur un hôte Windows. L’Assistant d’installation NMC affiche le message « Impossible de vérifier le nom d’hôte et/ou le port du serveur d’authentification ». ...
Symptômes
- NetWorker Management Console (NMC) est installé (ou en cours d’installation) sur un hôte Windows.
- L’assistant d’installation tente de vérifier le serveur d’authentification NetWorker qui doit être utilisé pour l’authentification NetWorker.
- L’installation ne parvient pas à valider le serveur d’authentification.
Unable to verify Authentication Server's hostname and/or port. If you were prompted, but did not install the certificate, try again by selecting view certificate and installing it under root certification authority. In no prompt was made for certificate validation, then verify that the NetWorker Authentication service is running on the configured host and port.

Le serveur NMC peut résoudre le serveur d’authentification et se connecter au port d’authentification (9090 par défaut). Commande Powershell :
tnc AUTHC_HOSTNAME -p 9090
L’installation manuelle du certificat de serveur AUTHC ne résout pas le problème : NMC: L’installation échoue avec l’erreur « Impossible de vérifier le nom d’hôte ou le port du serveur d’authentification »
Le serveur d’authentification authc-server.log Montre:
- Linux :
/nsr/authc/logs/authc-server.log - Windows (par défaut) :
C:\Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\authc-server.log
ERROR Context initialization failed org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'dataSourceInitializer' defined in class path resource [serviceConfig.xml]: Invocation of init method failed; nested exception is org.h2.jdbc.JdbcSQLNonTransientConnectionException: Unsupported database file version or invalid file header in file "C:/Program Files/EMC NetWorker/nsr/authc-server/tomcat/data/authcdb.mv.db"
Cause
Corruption de l’authentification NetWorker. L’erreur spécifique observée dans le authc-server.log peut se produire si NetWorker est mis à niveau en effectuant une désinstallation, puis une installation d’une nouvelle version, au lieu d’utiliser l’option « upgrade ». La mise à niveau des fichiers AUTHC n’a pas été gérée correctement à l’aide de cette méthode de mise à niveau.
Résolution
Réinstallez NetWorker avec un nouveau dossier AUTHC pour le forcer à remplacer le dossier existant.
Ces étapes ne suppriment pas la configuration ou les bases de données NetWorker. Il n’y a aucun risque pour les sauvegardes historiques.
- Arrêtez NetWorker :
net stop nsrexecd /y - Désinstaller NetWorker (et NMC, si sur le même serveur)
- Renommez le fichier binaire
C:\Program Files\EMC NetWorker\nsr\authc-serverDossier - Installez NetWorker (cela crée une nouvelle configuration AUTHC)
- Installer NMC
Une fois l’opération terminée, les services doivent démarrer et la connexion NMC peut être testée.
Si le mot de passe administrateur NMC précédent ne fonctionne pas, suivez les étapes décrites dans la section pour le réinitialiser. NetWorker : Réinitialisation du mot de passe administrateur
Informations supplémentaires
Si vous avez précédemment remplacé les certificats AUTHC ou intégré AD/LDAP avec le serveur AUTHC, ces paramètres doivent être reconfigurés :