Connectrix Brocade:「處理器重新開機 - 軟體錯誤:ASSERT」

Résumé: 本文說明當交換器因「處理器重新開機 - 軟體錯誤:ASSERT」錯誤而重新開機時的因應措施。

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

交換器因下列錯誤而重新開機:

Processor rebooted - Software Fault:ASSERT

 

Cause

「Software Fault:ASSERT」是軟體問題,發生在 CP1 (較早為使用中) 時,它會容錯移轉至另一個 CP 0 (較早的待機狀態)
此問題出在路由服務中,嘗試擷取資料時收到 null 指標。

 

容錯移轉後:

Fabric OS: v7.1.1c1

hadump        :
---------------------------------------
TIME_STAMP: Mar  7 11:23:37.498073
---------------------------------------
Local CP (Slot 6, CP0): Active, Cold Recovered
Remote CP (Slot 7, CP1): Standby, Healthy
HA enabled, Heartbeat Up, HA State synchronized

errdump:
2019/03/04-00:22:05, [HAM-1004], 30432, SLOT 7 | CHASSIS, INFO, ED_DCX8510_8B, Processor rebooted - Software Fault:ASSERT.


Core.pd file:

MSR: 00029200 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 0/0
TASK = b06c8e10[1869] 'RTEK_TH' Last syscall: -1
ASSERT - Failed expression: op != NULL,
         file = /vobs/projects/springboard/build/swbd62/fabos/src/sys/lib/fabos/fabobj_mgr/fabmedia.c, line = 183, kernel mode
         args = 0


set_reboot_reason reason=Software Fault:ASSERT
Kernel panic - not syncing: fabos assertion failed cpu 0:
ASSERT - Failed expression: op != NULL,
         file = /vobs/projects/springboard/build/swbd62/fabos/src/sys/lib/fabos/fabobj_mgr/fabmedia.c, line = 183
         args = 0

PD Start
PowerPC Book-E Watchdog Shutdown soft timer
PLATFORM_FIRST
MTRACER
mtracer_panicdump
mtracer_panicdump write=0x44a1
reboot_reason
PD_MISC
CONSOLE_LOG
6300 KBytes in 2 file(s)
use "supportsave" command to upload

 

Résolution

路由服務中存在軟體缺陷,導致 Brocade 缺陷 DEFECT000440968發生故障。
此問題的修正是將交換器升級至 FOS 7.4.x 及更新版本。

 

Produits concernés

Connectrix
Propriétés de l’article
Numéro d’article: 000055899
Type d’article: Solution
Dernière modification: 17 Apr 2026
Version:  4
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.