PowerProtect : Échec de la copie entre comptes du plan de protection Cloud Snapshot Manager en raison d’une erreur de partage de clés

Résumé: Les snapshots ne sont pas créés dans le compte DR sécurisé car les clés de chiffrement ne sont pas accessibles dans le compte source lorsqu’ils sont accessibles à partir du compte DR sécurisé. ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Les snapshots ne sont pas créés dans le compte DR sécurisé.
L’erreur suivante est signalée pour la copie de snapshot inter-comptes :
« Erreur : L’ID de clé donné n’est pas accessible »

Cause

Les clés de chiffrement du compte source de snapshot ne sont pas accessibles à partir du compte DR sécurisé.

Résolution

Ajoutez le compte de reprise après sinistre sécurisé aux comptes qui ont accès aux clés de chiffrement requises dans le compte source du snapshot. 
Pour les clés associées aux snapshots envoyés à un compte DR sécurisé, utilisez le bouton « Add other AWS accounts » de la section Customer-Managed Keys dans AWS.

Cela signifie que le compte DR sécurisé doit être en mesure d’accéder aux clés de chiffrement stockées dans le compte. 

L’utilisateur ou le rôle IAM dans le compte cible doit être en mesure d’exécuter la clé DescribeKey, (lien externe) CreateGrant  (lien externe) et Decrypt (Lien externe) sur la clé associée au snapshot d’origine. L’utilisateur ou le rôle doit également être en mesure d’effectuer l’opération CreateGrant (Lien externe)Encrypt (Lien externe)Decrypt (Lien externe)DescribeKey (Lien externe), et GenerateDataKeyWithoutPlaintext (Lien externe) sur la touche associée à l’appel à CopySnapshot (Lien externe).
Consultez cet article pour plus d’informations :
https://aws.amazon.com/blogs/aws/new-cross-account-copying-of-encrypted-ebs-snapshots/ (Lien externe)

Produits concernés

Cloud Backup & Protection, Cloud Snapshot Manager, PowerProtect Cloud Snapshot
Propriétés de l’article
Numéro d’article: 000199039
Type d’article: Solution
Dernière modification: 09 Oct 2024
Version:  2
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.