VxRail: Health check fails for test 'rep_partnr'
Résumé: Dell VxRail: Health check fails for test 'rep_partnr'.
Symptômes
The test works only for VxRail > 7.0.200.
The test works only if SSO Admin credentials were given.
The 'rep_partnr' test checks the vCenter replication partner's status.
| Test Result | Result code | Result Interpretation |
| Pass | 0 | No replication is present or all replication partners are available. |
| Warning | 1 | This test has no warning result. |
| Failure | 2 | This indicates that there is an issue with replication. |
| Critical | 3 | This test has no critical result. |
An example of the health-check output, when RecoverPoint for Virtual Machines (VMs) is present, is shown below:
#========================#======#=========#====================================================================#==============# | Hostname / Category |Status Dell_KB | Warnings or Failures, unless tests Passed ; Product S.N. | #========================#======#=========#====================================================================#==============# | vCenter_admin | Failure 213713 | rep_partnr: Not all replication partners available. .|
Cause
This test was created for environments where the embedding of the Platform Service Controller (PSC) when upgrading to 7.0 did not clean up the replication. This has no impact on in-family upgrades but stops an out of family upgrade.
This might also fail if Enhanced Link Mode (ELM) is used and there is an issue with the expected replication.
All replication partners with issues are listed in the vxv.log.
To find the offending ones, use this command:
grep "rep_partnr" vxv.log
Example from Lab:
vcluster101-vxrm:/home/mystic # grep "rep_partnr" /tmp/vxv/vxv.log
2023-05-18 14:17:22-INFO [rep_partnr] Testing replication status
2023-05-18 14:17:22-ERROR [rep_partnr] ERROR - Not all replication partners available [[{'node': 'vcluster101-vcsa.vv001.local', 'status_available': False, 'partner_available': False, 'replication_partner': 'vcluster101-psc.vv001.local'}]].
Résolution
The replication nodes listed with a 'False' value in 'status_available' or 'partner_available' must be investigated. If assistance is needed, open a support ticket with Dell support.