NetWorker : impossible de créer un client dans NMC « impossible de déterminer le nom de l’adresse « null »

Résumé: Impossible de créer un client à l’aide de l’Assistant Nouveau client dans NMC.

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Symptômes

Le message suivant s’affiche lors de la tentative de création d’un nouveau client dans NetWorker Management Console (NMC) :

Connecting to host client_name failed:
The host reports: Unable to create a session channel with nsrexecd on host client_name to execute the command ‘nsrfsra’: Unable to determine the name of address ‘null’ — Hostname.

Cause

nsrexecd_nsrfa fournit la fonctionnalité d’accès aux fichiers à distance utilisée par le serveur NetWorker lorsqu’il doit communiquer avec un client pour des opérations impliquant la récupération de fichiers et de métadonnées sur RPC.

Impossible de créer le canal pour l’accès distant aux fichiers à l’aide de nsrexecd .

Raisons possibles :

  • DNS/recherche inversée erronée
  • Le service nsrexecd du client n’est pas en cours d’exécution
  • Non-correspondance de la plage de ports

De plus, si le fichier servers dans la res a une entrée incorrecte :

  • Corrompu
  • Contient un ancien nom de serveur,
  • Contient des entrées en double,
  • Entrées de nom d’hôte/DNS incorrectes dans le fichier servers.
  • Le format de fichier des serveurs est endommagé

Résolution

Pour résoudre cette erreur, effectuez les vérifications et actions suivantes :
 

  1. Vérifier la résolution de noms et la communication
    1. Assurez-vous que la résolution de noms fonctionne correctement dans les deux sens :  Server → Client et Client → Server à l’aide de 'nslookup', et vérifiez que chaque nom d’hôte se résout correctement
    2.  Validez les ports requis : Vérifiez que les ports de service NetWorker obligatoires 7937 et 7938 sont accessibles entre le serveur et le client.  

À partir du NetWorker Server et du NetWorker Client, utilisez la commande nsrports Commande permettant de valider la résolution de noms et la communication des ports 7937 et 7938 :

nsrports -t HOSTNAME -p PORT

Exemple de résultat :

[root@nsr ~]# nsrports -t rhel-client01.amer.lan -p 7937
Forward lookup for rhel-client01.amer.lan
Query time:              0.001 sec
Canonical name (CNAME):  rhel-client01.amer.lan
Address (A):             192.168.9.121
Connect to port 7937:    Succeeded (0.001 sec)

Reverse lookup for 192.168.9.121
Query time:              0.001 sec
Name:                    rhel-client01.amer.lan

Pour plus d’informations, consultez la section : NetWorker : Utilisation de la commande nsrports

AVERTISSEMENT : Tout échec de résolution de noms ou de connexion de port doit être résolu par l’administrateur système ou l’équipe de sécurité réseau.

 

  1. Vérifiez que le NetWorker Server peut voir nsrexecd_nsrfa sur le client NetWorker :
nsrrpcinfo -p CLIENT_NAME
Exemple :
[root@nsr ~]# nsrrpcinfo -p rhel-client01.amer.lan
PROGRAM VERSION PROTOCOL PORT SERVICE
100000  2       tcp      7938 nsrportmapper  Port Mapper
100000  2       udp      7938 nsrportmapper  Port Mapper
390436  1       tcp      8359 nsrexecd       GSS Authentication
390435  1       tcp      9613 nsrexecd       Resource Mirror
390113  1       tcp      7937 nsrexecd       Remote Execution
390440  1       tcp      8942 nsrexecd_nsrfa Remote File Access
Pour plus d’informations, consultez la section : NetWorker : À l’aide de la commande NetWorker « nsrrpcinfo »
 
Remarque : Si nsrexecd et nsrexecd_nsrfa sont répertoriés, cela signifie que le NetWorker Server peut voir ces processus et ports sur le client. Passez à l’étape 4. Si le serveur ne parvient pas à détecter ces processus, passez à l’étape 3.
  1. Si le serveur ne voit pas nsrexecd ou nsrexecd_nsrfa sur le client, effectuez les actions suivantes sur le système client :
    1. Vérifiez que le service client est en cours d’exécution :
  • Linux : ps -ef | grep nsr
  • Windows. : sc query nsrexecd
  1. Si le client n’est pas en cours d’exécution, essayez de démarrer les services :
  • Linux : systemctl start networker
  • Windows. : net start nsrexecd
Surveillez les paramètres daemon.raw Pour les erreurs au cas où le service ne démarre pas :
  1. Si les services client sont en cours d’exécution, vérifiez si le nsrexecd_nsrfa est en cours d’exécution.
  • Si le logiciel « Extended Client » est installé sur le client, vous pouvez vérifier auprès de nsrrpcinfo -p localhost. Cette commande doit afficher à la fois nsrexecd et nsrexecd_nsrfa Exécution. La commande nsrrpcinfo n’est pas disponible sur les systèmes sur lesquels seul le package client standard est installé.
  • Si le logiciel Extended Client n’est pas installé sur le client, seuls les voyants nsrexecd en cours d’exécution avec les commandes du système d’exploitation, vous ne verrez pas nsrexecd_nsrfa. Vous devez valider à partir du NetWorker Server si vous voyez nsrexecd_nsrfa écoute sur le client (voir étape 2).
    1. Vérifiez la plage de ports NetWorker utilisée sur le client à l’aide de nsrports . La plage de ports par défaut est 7937-9936. Voir : NetWorker : Utilisation de « nsrports -s » pour modifier la plage de ports de service NetWorker

 

  1. Vérifiez si le client dispose d’un fichier « servers » dans son dossier « res » :
    • Linux : /nsr/res
    • Windows (par défaut) : C:\Program Files\EMC NetWorker\nsr\res
Remarque : Le fichier servers agit comme une « politique d’accès » ; Sens: « Seuls les serveurs NetWorker définis dans ce fichier sont autorisés à me sauvegarder. »
    1. S’il existe un fichier servers, l’une des conditions suivantes doit être vérifiée :
    • Il doit être vide (tous les serveurs sont autorisés)
    • Si des serveurs sont définis dans le fichier, le NetWorker Server à partir duquel vous avez tenté d’ajouter ce client doit être défini dans le fichier.
    1. S’il n’y a pas de problèmes évidents avec le fichier, il est peut-être corrompu. Renommez le fichier et redémarrez les services :
    • Linux : systemctl restart networker
    • Windows. : net stop nsrexecd && net start nsrexecd

Après avoir effectué toutes les étapes de validation ci-dessus, essayez d’ajouter le client au NetWorker Server.

Informations supplémentaires

Produits concernés

NetWorker
Propriétés de l’article
Numéro d’article: 000437991
Type d’article: Solution
Dernière modification: 14 Mar 2026
Version:  1
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