NetWorker : impossible de créer un client dans NMC « impossible de déterminer le nom de l’adresse « null »
Résumé: Impossible de créer un client à l’aide de l’Assistant Nouveau client dans NMC.
Symptômes
Le message suivant s’affiche lors de la tentative de création d’un nouveau client dans NetWorker Management Console (NMC) :
Connecting to host client_name failed: The host reports: Unable to create a session channel with nsrexecd on host client_name to execute the command ‘nsrfsra’: Unable to determine the name of address ‘null’ — Hostname.
Cause
nsrexecd_nsrfa fournit la fonctionnalité d’accès aux fichiers à distance utilisée par le serveur NetWorker lorsqu’il doit communiquer avec un client pour des opérations impliquant la récupération de fichiers et de métadonnées sur RPC.
Impossible de créer le canal pour l’accès distant aux fichiers à l’aide de nsrexecd .
Raisons possibles :
- DNS/recherche inversée erronée
- Le service nsrexecd du client n’est pas en cours d’exécution
- Non-correspondance de la plage de ports
De plus, si le fichier servers dans la res a une entrée incorrecte :
- Corrompu
- Contient un ancien nom de serveur,
- Contient des entrées en double,
- Entrées de nom d’hôte/DNS incorrectes dans le fichier servers.
- Le format de fichier des serveurs est endommagé
Résolution
Pour résoudre cette erreur, effectuez les vérifications et actions suivantes :
- Vérifier la résolution de noms et la communication
- Assurez-vous que la résolution de noms fonctionne correctement dans les deux sens : Server → Client et Client → Server à l’aide de '
nslookup', et vérifiez que chaque nom d’hôte se résout correctement - Validez les ports requis : Vérifiez que les ports de service NetWorker obligatoires 7937 et 7938 sont accessibles entre le serveur et le client.
- Assurez-vous que la résolution de noms fonctionne correctement dans les deux sens : Server → Client et Client → Server à l’aide de '
À partir du NetWorker Server et du NetWorker Client, utilisez la commande nsrports Commande permettant de valider la résolution de noms et la communication des ports 7937 et 7938 :
nsrports -t HOSTNAME -p PORT
Exemple de résultat :
[root@nsr ~]# nsrports -t rhel-client01.amer.lan -p 7937 Forward lookup for rhel-client01.amer.lan Query time: 0.001 sec Canonical name (CNAME): rhel-client01.amer.lan Address (A): 192.168.9.121 Connect to port 7937: Succeeded (0.001 sec) Reverse lookup for 192.168.9.121 Query time: 0.001 sec Name: rhel-client01.amer.lan
Pour plus d’informations, consultez la section : NetWorker : Utilisation de la commande nsrports
- Vérifiez que le NetWorker Server peut voir
nsrexecd_nsrfasur le client NetWorker :
nsrrpcinfo -p CLIENT_NAME
[root@nsr ~]# nsrrpcinfo -p rhel-client01.amer.lan PROGRAM VERSION PROTOCOL PORT SERVICE 100000 2 tcp 7938 nsrportmapper Port Mapper 100000 2 udp 7938 nsrportmapper Port Mapper 390436 1 tcp 8359 nsrexecd GSS Authentication 390435 1 tcp 9613 nsrexecd Resource Mirror 390113 1 tcp 7937 nsrexecd Remote Execution 390440 1 tcp 8942 nsrexecd_nsrfa Remote File Access
- Si le serveur ne voit pas nsrexecd ou nsrexecd_nsrfa sur le client, effectuez les actions suivantes sur le système client :
- Vérifiez que le service client est en cours d’exécution :
- Linux :
ps -ef | grep nsr - Windows. :
sc query nsrexecd
- Si le client n’est pas en cours d’exécution, essayez de démarrer les services :
- Linux :
systemctl start networker - Windows. :
net start nsrexecd
daemon.raw Pour les erreurs au cas où le service ne démarre pas :
- Linux :
/nsr/logs/daemon.raw - Windows (par défaut) :
C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw - NetWorker : Utilisation de nsr_render_log pour afficher .raw fichiers journaux
- Si les services client sont en cours d’exécution, vérifiez si le
nsrexecd_nsrfaest en cours d’exécution.
- Si le logiciel « Extended Client » est installé sur le client, vous pouvez vérifier auprès de
nsrrpcinfo -p localhost. Cette commande doit afficher à la foisnsrexecdetnsrexecd_nsrfaExécution. La commandensrrpcinfon’est pas disponible sur les systèmes sur lesquels seul le package client standard est installé. - Si le logiciel Extended Client n’est pas installé sur le client, seuls les voyants
nsrexecden cours d’exécution avec les commandes du système d’exploitation, vous ne verrez pasnsrexecd_nsrfa. Vous devez valider à partir du NetWorker Server si vous voyeznsrexecd_nsrfaécoute sur le client (voir étape 2).
-
- Vérifiez la plage de ports NetWorker utilisée sur le client à l’aide de
nsrports. La plage de ports par défaut est 7937-9936. Voir : NetWorker : Utilisation de « nsrports -s » pour modifier la plage de ports de service NetWorker
- Vérifiez la plage de ports NetWorker utilisée sur le client à l’aide de
- Vérifiez si le client dispose d’un fichier « servers » dans son dossier « res » :
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- Linux :
/nsr/res - Windows (par défaut) :
C:\Program Files\EMC NetWorker\nsr\res
- Linux :
-
- S’il existe un fichier servers, l’une des conditions suivantes doit être vérifiée :
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- Il doit être vide (tous les serveurs sont autorisés)
- Si des serveurs sont définis dans le fichier, le NetWorker Server à partir duquel vous avez tenté d’ajouter ce client doit être défini dans le fichier.
-
- S’il n’y a pas de problèmes évidents avec le fichier, il est peut-être corrompu. Renommez le fichier et redémarrez les services :
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- Linux :
systemctl restart networker - Windows. :
net stop nsrexecd && net start nsrexecd
- Linux :
Après avoir effectué toutes les étapes de validation ci-dessus, essayez d’ajouter le client au NetWorker Server.