Avamar : Le serveur MCS reçoit les messages « OutOfMemory »
Résumé: Le serveur MCS (Avamar Management Console Server) reçoit des messages « Mémoire insuffisante » en raison d’un fichier NVRAM volumineux provenant d’une machine virtuelle.
Symptômes
Les sauvegardes VMware et physiques planifiées semblent ne pas répondre.
Ils peuvent apparaître comme étant en cours d’exécution dans la fenêtre Avamar Administrator Activity, mais sans modification des octets de progression.
Le serveur MCS (Management Console Server) signale une condition d'« inutilisation de la mémoire » et l’interface utilisateur peut être lente à répondre.
Les clients VMware ne s’enregistrent pas pendant de longues périodes.
Cause
Lors de la sauvegarde des machines virtuelles, le serveur MCS charge les fichiers NVRAM (Non-Volatile Random Access Memory) dans son javaheap pour lire la configuration du BIOS.
Le fichier NVRAM se trouve au même emplacement que VMware *.vmdk fichiers qui se trouvent sur le datastore.
Il arrive parfois qu’un fichier NVRAM, dont la taille n’est généralement que de quelques Ko (moins de 10 Ko) atteigne environ 1 Mo ou plus.
Il n’en faut pas plus pour que MCS javaheap pour manquer de mémoire.
Résolution
1. Connectez-vous à Avamar Utility Node et chargez les clés d’administrateur. Pour obtenir des instructions sur le chargement des clés, consultez Avamar : Connexion à un serveur Avamar et chargement de différentes clés.
2. Vérifiez si l’option javaheap est déjà défini sur 1,5 Go, ce qui est indiqué par « -Xmx1536m » dans la sortie ci-dessous :
ps -elf | grep java | grep mcserver
0 S admin 13623 1 2 76 0 - 556102 - 16:54 pts/0 00:10:16
/usr/java/jre1.6.0_22/bin/java -Xmx1536m -XX:MaxPermSize=256m -server -ea -cp
.:/usr/local/avamar/lib/mcserver.jar:/usr/local/avamar/lib/asn_server.jar:/usr/local/avamar/lib/mail.jar:/usr/local/avamar/lib/activation.jar:/usr/local/avamar/lib/xercesImpl.jar:/usr/local/avamar...<snip>...
6.1.23.jar:/usr/local/avamar/lib/jetty-util-6.1.23.jar:/usr/local/avamar/lib/servlet-api-2.5.jar:/usr/local/avamar/lib/jsp-api-2.1.jar:/usr/local/avamar/lib/jsp-
3. Vérifiez si les messages « OutOfMemory » sont signalés dans le journal (en raison d’une NVRAM potentiellement volumineuse) :
grep -hi "OutOfMemoryError\|VMware" /usr/local/avamar/var/mc/server_log/mcserver.log*
Exception in thread "Thread-191" java.lang.OutOfMemoryError: Java heap space
at java.util.Arrays.copyOf(Unknown Source)
at java.io.ByteArrayOutputStream.write(Unknown Source)
at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.readVmFile(VmwareVirtualMachineFiles.java:386)
at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.getVirtualMachineFile(VmwareVirtualMachineFiles.java:109)
at
com.avamar.mc.vmware.VmwareVirtualCenter.getVirtualMachineFile(VmwareVirtualCenter.java:902)
at
com.avamar.mc.vmware.VmwareService.getNvramFileContent(VmwareService.java:2596)
at com.avamar.mc.wo.JobScheduler._gotVmWork(JobScheduler.java:530)
at com.avamar.mc.wo.JobScheduler.gotVmWork(JobScheduler.java:327)
at com.avamar.mc.wo.DPNScheduler.gotVmWork(DPNScheduler.java:144)
4. Vérifiez quels clients disposent de la grande NVRAM :
grep "nvramContent\=\"null\"" mcserver.log.*
Cet exemple de sortie indique les rapports « Company_1_Email-PDB » du client"nvramContent="null"':
FINE: MCS to Client(10.n.n.64:39270) Response: <workorder work="backup" type="work" ack="yes" cid="8580a6233796c72a4a73b89f0d2ae5fb644fcbd0" sync="bg"
wid="NFSSQLCluster-1350439200070" pid="vmimagew" pidnum="3016" msgver="5" sessionid="c61b498fdf57eaca6cadc760a3b7fbf6f7e89aea"
targetCid="bae291d2ba3d3e3ea77d5394bcaa60da3a072463" targetUUID="500faaf4-8f4b-b5f2-1744-1277d19a79cf" vcCid="3a25059a880e1d22b981c5815858d3dc95312621"
time="1350442682" customaction="" ><targetlist><path name="[nas_datastore_03] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="85899345920">
</path><path name="[nas_datastore_03_sqldb] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="171798691840"></path>
<path name="[nas_datastore_03_sqllogs] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="32212254720"></path></targetlist><directives>
<flag type="string" name="encrypt" value="proprietary" /> <flag type="string" name="encrypt-strength" value="cleartext" /> <flag type="string" name="expire"
value="1353034800" /> <flag type="string" name="retention-type" value="daily,weekly,monthly,yearly"
....
"TRUE"scsi0:2.deviceType = "scsi-hardDisk"scsi0:2.present = "TRUE"scsi0:2.redo = ""migrate.hostlog = "
./Company_1_Email-PDB-b5986b60.hlog"scsi0:0.ctkEnabled = "TRUE"ctkEnabled = "TRUE"sched.scsi0:1.shares = "normal"
ethernet1.virtualDev = "vmxnet3"ethernet1.pciSlotNumber = "192"ethernet1.startConnected = "TRUE"
ethernet1.allowGuestConnectionControl = "TRUE"ethernet1.features = "1"ethernet1.wakeOnPcktRcv = "TRUE"
ethernet1.addressType = "vpx"ethernet1.generatedAddress = "00:00:56:8f:3f:b1"ethernet1.networkName = "
VM Network - 117"ethernet1.present = "TRUE"" nvramContent="null" prevBackup="null" snapshotDesired="always" prevSnapName="null" >
</vmInfo><vmDiskInfoList numDisks="3" > <vmDiskInfo capacityInKB="83886080" vmdkFilename="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk"
vmdkBaseFile="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk" ordinal="1" srcOrdinal="-1" label="Hard disk 1" diskKey="2000"
datastoreUrl="ds:///vmfs/volumes/e4b3f733-24646679/" datastore="nas_datastore_03"
nvramcontent de sorte que toutes les instances doivent être examinées.
5. Une fois que le ou les clients dotés de la grande NVRAM sont identifiés à partir des journaux :
un. Redémarrez le client pour qu’il crée un nouveau fichier NVRAM.
B. Si le problème se produit pour le même client, créez une demande de service auprès de l’équipe de support technique Dell Technologies.
6. Si le message d’erreur persiste, reportez-vous à Avamar : Code symptôme 22402 - Desc : Impossible d’enregistrer les données du serveur de la console sur le serveur (chemin de résolution) pour un dépannage supplémentaire.