NVP-vProxy: Errori continui di accesso da vProxy

Résumé: NVP-vProxy: Errori continui di accesso da vProxy: Impossibile completare l'accesso a causa di nome utente o password errati.

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Symptômes

Errori di accesso continui da un vProxy a un vCenter vengono visualizzati nel vbackupd.engine.log quando il debug è abilitato. L'errore si verifica ogni 5 minuti.
2024-07-18T14:02:54Z INFO: Request #83: Deleted resource: vCenter.com:vm-xxxxxx - xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx. 
2024-07-18T14:02:54Z DEBUG: backupEngine Consumer: establish connection 
2024-07-18T14:02:54Z DEBUG: backupEngine Consumer: get channel 0 
2024-07-18T14:02:54Z TRACE: Request #83: Reply sent successfully for 'DeleteSession'. 
2024-07-18T14:02:54Z TRACE: Purged 0 aged files in '/opt/emc/vproxy/runtime/logs/recycle/daemon'. 
2024-07-18T14:02:56Z ERROR: CleanupMgr: vCenter.com: Scrubber: Unable to log in to vCenter 'vCenter.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password. 
2024-07-18T14:06:18Z DEBUG: Session keepalive on vCenter 'vCenter.com' 
2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Sending 1 requests to scrubber ... 
2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Sent requests to scrubber. 
2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Scrubber: Received 1 requests to scrub. 
2024-07-18T14:07:52Z TRACE: CleanupMgr: vCenter.com: Scrubber: Logging into vCenter 'vCenter.com' 
2024-07-18T14:07:55Z ERROR: CleanupMgr: vCenter.com: Scrubber: Unable to log in to vCenter 'vCenter.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password. 
2024-07-18T14:11:18Z DEBUG: Session keepalive on vCenter 'vCenter.com'

Cause

I file InventorySessions.gob del vProxy vengono usati per archiviare le informazioni di sessione per il servizio nsrvisd del server NetWorker. L'estensione .gob suggerisce che questi file sono nel formato Go Binario, che può contenere informazioni sulla sessione relative alla gestione dell'inventario. In alcuni casi, questo file potrebbe non essere stato pulito e ha memorizzato nella cache informazioni obsolete sulle credenziali vCenter. In alcuni casi, il file InventorySessions.gob potrebbe non essere eliminato durante la pulizia con conseguente tentativo di accesso non riuscito.

Résolution

La soluzione alternativa consigliata consiste nel rinominare la cartella /data01/runtime/state/vbackupd/ o eliminare il file .gob.

1. Aprire una sessione SSH nell'appliance vProxy e accedere come amministratore.
2. Una volta effettuato l'accesso, passare a root:
sudo su -
3. Arrestare il servizio vbackupd:
systemctl stop vbackupd
4. Rinominare la directory /data01/runtime/state/vbackupd/:
mv /data01/runtime/state/vbackupd/ /data01/runtime/state/vbackupd_`date -I`.bak
5. Ricaricare i daemon vProxy:
systemctl daemon-reload
6. Avviare vbackupd:
systemctl start vbackupd
Viene creata una nuova directory /data01/runtime/state/vbackupd/.

Informations supplémentaires

Verificare che gli appliance vProxy implementati siano aggiornati alla versione principale più recente supportata dal server NetWorker:
NVP vProxy: Come aggiornare l'appliance NVP vProxy utilizzando nsrvproxy_mgmt.
Propriétés de l’article
Numéro d’article: 000227670
Type d’article: Solution
Dernière modification: 01 May 2026
Version:  2
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