Dell Unity:Unityを5.1にアップグレードした後、VMwareアプライアンス管理インターフェイスを使用して、vCenter ServerアプライアンスをUnity NFS共有にバックアップできない

Résumé: Unityを5.1にアップグレードした後、VMware Appliance Management Interface(VAMI)を使用したVCSA(vCenter Server Appliance)バックアップが完了しませんでした。これは、Unity 5.1以降のコードの問題が原因で、マウント パスにスラッシュ「/」が追加されたときにvCenterからのマウント リクエストを拒否します。 ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Unityを5.1にアップグレードした後、VMware Appliance Management Interface(VAMI)を使用してUnity NFSエクスポートへのVCSA(vCenter Server Appliance)バックアップを実行できないことにユーザーが気付きました。Unityコードのアップグレード前に、同じNFSバックアップ パスが機能していた。

この問題は、特定のシナリオでのみ発生します。

  • NFS共有は、ファイル システムのサブフォルダーに作成されます。 
  • NFS共有名は、ファイル システム名と同じです。 
  • NASサーバーで有効になっているのはNFSv3のみです。 

次に、バックアップの問題が発生したNFSエクスポート構成の例を示します。

FS名:テスト
FSパス: /test
NFSエクスポート ローカル パス: /test/subfolder
NFSエクスポート名:test 


VAMIのバックアップの場所は 、nfs://< nfsサーバーのipアドレス/fqdn>:/testです。

バックアップ スケジュールの作成エラー メッセージの例
図1: バックアップ スケジュールの作成エラー メッセージの例


vCenter /var/log/vmware/applmgmt/applmgmt.logから、アクセスが拒否されたため、マウント リクエストが失敗しました。 

2023-04-06T01:22:04 AM UTC [2182]ERROR:plugins.MountedFSStorageIOLib:Cmd ['/usr/bin/mount', '-t', 'nfs', '5.6.7.12:/test/', '/storage/remote/backup/nfs/5.6.7.12/BKCA6Hf0/lrcCF3e2', '-o', 'hard,intr'] failed. rc: 32, stdout: , stderr: mount.nfs: access denied by server while mounting 5.6.7.12:/test/

2023-04-06T01:22:04 AM UTC [2182]INFO:plugins.MountedFSStorageIOLib:Failed to mount the nfs share 5.6.7.12:/test/ at /storage/remote/backup/nfs/5.6.7.12/BKCA6Hf0/lrcCF3e2. Err- rc: 32, out=, err=mount.nfs: access denied by server while mounting 5.6.7.12:/test/

2023-04-06T01:22:04 AM UTC [2182]ERROR:plugins.MountedFSStorageIOLib:Didn't mount the remote filesystem root.

Cause

デフォルトでは、UnityでNFSエクスポートが作成されると、2つのパスがエクスポートされます。最初のパスはファイル システムのローカル パスで、もう1つのパスはエクスポートされたパスです。これは、共有の作成時にユーザーが指定した共有の名前です。

たとえば、ユーザーはファイル システム「test_fs」を作成します。NASサーバーのルート パーティション上の「/test_fs」にマウントされます。ユーザーがNFS共有「test_export」としてファイル システム「test_fs」のルート パーティション「/test_fs」をエクスポートした場合、クライアントはこのエクスポートに対して次のように2つのマウント パスを参照します。 
[root@rhel8 ~]# showmount -e 5.6.7.12
Export list for 5.6.7.12:
/test/subfolder (everyone) >>>>  local path of the file system 
/test           (everyone) >>>> exported path (Share name)

NASサーバー上の showExportLevel という名前のパラメーターは、両方のパスを表示するか、クライアントがshowmountを実行しているときにいずれかのパスのみを表示するかを制御します。パスが1つだけ見られる場合は、このパラメーターのデフォルト以外の値が構成されている可能性があります。 
22:38:41 service@ABCDEFG spa:~/user# svc_nas Test_server -param -f nfs -i showExportLevel

Test_server :
name                    = showExportLevel
facility_name           = nfs
default_value           = 0
current_value           = 0
configured_value        = 0
param_type              = NAS server
user_action             = none
change_effective        = immediate
range                   = (0,2)
description             = An export is defined by both the exported path and the name of the export. By default the server reports both entries in the 'showmount -e' query. When set, this param will filter one or the other kind: Value=1 will report only the exported paths, Value=2 will report only the export names.

VAMIを使用したバックアップが失敗する理由は、VAMIがバックアップ パスにスラッシュ「/」を追加するためです。Unityのコードの問題により、パスはUnityによって無効として扱われ、マウント リクエストは拒否されます。

たとえば、バックアップ パスが「nfs://5.6.7.12:/test」として構成されている場合、vCenterはパス「nfs://5.6.7.12:/test/」を使用してNFSエクスポートをマウントしようとし、Unityはマウント リクエストを拒否します。

マウント パスにスラッシュ「/」が追加されている場合、Linuxクライアントでもこの問題が発生する可能性があります。 
[root@rhel8 ~]# showmount -e 5.6.7.12
Export list for 5.6.7.12:
/test/subfolder (everyone)
/test           (everyone)

[root@rhel8 /]# mount 5.6.7.12:/test/ /mnt
mount.nfs: access denied by server while mounting 5.6.7.12:/test/

[root@rhel8 /]# mount 5.6.7.12:/test /mnt
[root@rhel8 /]#

Résolution

永続的な修正は、次のUnityコード リリースで利用可能になる予定ですが、日付は暫定的であり、変更される可能性があります。  

コード リリースが利用可能になるまで使用できる回避策は2つあります。 
  • NFSローカル パスを使用して、VAMIでバックアップを実行します。 
  • NASサーバーでNFSv4を有効にします。 

Produits concernés

Dell EMC Unity, Dell Unity Operating Environment (OE)
Propriétés de l’article
Numéro d’article: 000212114
Type d’article: Solution
Dernière modification: 26 Jun 2023
Version:  5
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.