PowerStore:NDUアップグレード前のヘルス チェックに「Failed in execution of pre-upgrade health check status of NAS subsystem」と表示される(英語)」

Résumé: NASサブシステムのステータスをチェックすると、NDUアップグレード前ヘルス チェックが失敗します。

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Symptômes

Error code:
0xE0403001000C エラー メッセージ: NASサブシステムのアップグレード前ヘルス チェック ステータスの実行に失敗しました。

Cause

PowerStore TアプライアンスがNASサブシステムを実行している場合、NDUアップグレード前ヘルス チェック(PUHC)手順中に追加のNASヘルス チェックが実行されます。

いずれかのNASヘルス チェックで4(4=良好)未満のヘルス ステータスが表示された場合、アップグレードの全体的なヘルス チェックは失敗します。

アップグレード前ヘルス チェックのジョブの詳細に、「失敗」の項目が複数表示されることがあります。詳細をハイライトして表示することにより、各「Failed」行を確認します。      
Job Details:
説明
アップグレード前ヘルス チェックXに失敗しました
ノードAでアップグレード前ヘルス チェックが失敗しました。  詳細については、ヘルス チェックの手順を確認してください(0xE0403001000C)
Health check - node A                                      X Failed
NASサブシステムのアップグレード前ヘルス チェック ステータスの実行に失敗しました。Please check the alerts and events page for possible NAS errors and take corrective actions.(bsc_sdnas_puhc_executeStatusApi_error)

Résolution

「原因」セクションに記載されているジョブの詳細では、どのNASヘルス チェックで障害が発生したかを判断するための十分な手がかりが得られない場合があります。
  1. 失敗の原因を特定するには、クラスターのIPアドレスへのSSHセッションを開き、サービス ユーザーとしてログインします。どちらかにファイルが存在する可能性があるため、両方のノードを確認してください。
  2. UNIXツール「cat」を使用して次のファイルを表示すると、NASの問題に関する詳細が表示されます。内容を表示するには、ファイルへの完全なパスを使用する必要があります。
SLN320669_en_US__1icon メモ:  サービス ユーザーとしてログインすると、/home/service/userディレクトリーに移動します。

 

/home/service/user
[SVC: service@xxxxxxx-A ユーザー] $ cat /var/log/sdnas/ansible/123.221.xxx.xxx_sdnas_deploy_error.json
{
"128.221.xxx.xxx":
{"error_code": 「\"1131\"」、「
error_description": "\"クラスターの正常性ステータスは4ではありません。クラスターは正常な状態ではありません。\"",
"error_recommended_action": 「\"PowerStoreプラットフォームの場合、正常性イベントの詳細については、/var/log/sdnas/ansible/nas_health_events.logファイルを参照してください。さらにサポートが必要な場合は、サポートにお問い合わせください。\"",
"failed_task": "クラスターの正常性ステータスが4でない場合、メッセージで失敗する",
"日付/時刻": 「2020-03-17/17:10:13」、「
failed_command」: "",
"failed_command_rc": "",
"failed_command_stderr": 「ERROR! The health status of cluster is 3.クラスターには、4"、
"failed_command_stdout"の必要な正常性ステータスがありません。"", "failed_node
": "128.221.xxx.xxx"
}



}
[SVC:service@xxxxxxx-A user]$ cat /var/log/sdnas/ansible/nas_health_events.log
Cluster health Status=3
Event ID=5e71040c-0324-32ae-d4e4-56cb091ae676
Event fullDescription=DNS クライアントは設定された DNS サーバの一部に接続できませんが、まだ動作しています。\n これは、ネットワークの問題によりNASサーバーがピアDNSサーバーに到達できない場合に発生する可能性があります。
Event recommendedAction=Check the NAS server network interface and the router configuration.\n Or check the availability of the configured DNS server running the 'svc_cifssupport -checkup' or 'svc_nas -dns' command.
   名前=nasServer
、値=smb160
、イベント ID=5e710453-d4f8-4239-8b8e-5a3c89700de4
イベント fullDescription=DNS クライアントは、設定済みの DNS サーバの一部に接続できませんが、まだ動作しています。\n これは、ネットワークの問題によりNASサーバーがピアDNSサーバーに到達できない場合に発生することがあります。
Event recommendedAction=Check the NAS server network interface and the router configuration.\n Or check the availability of the configured DNS server running the 'svc_cifssupport -checkup' or 'svc_nas -dns' command.
   名前 = nasServer
値 = smb161

上記の例では、定義されたDNSサーバーの1つにアクセスできず、その状態を修正した後、NDUヘルス チェックに合格しました。
 


また、スクリプト svc_nas_toolssvc_nas_cifssupport を使用してSDNASを検証し、問題を見つけることもできます。サービス スクリプトの詳細については、『Dell EMC PowerStore Service Scripts Guide 』を参照してください。

DNS接続を確認する例:       

[SVC:service@xxxxxx-B user]$ svc_nas_tools --server nas121 --args="-dns"
nas121 : commands processed: 1
output is complete

1597753629: LIB: 6: DNS is running.
1597753629: LIB: 6: DNS active config: override
1597753629: LIB: 6: * VDM Config: global
1597753629: LIB: 6: abc123.lab.emc.com
1597753629: LIB: 6:   proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx
1597753629: LIB: 6: * VDM Config: local
1597753629: LIB: 6: abc123.lab.emc.com
1597753629: LIB: 6:   proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx
1597753629: LIB: 6: * VDM Config: override
1597753629: LIB: 6: abc123.lab.emc.com
1597753629: LIB: 6:   proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx
1597753629: LIB: 6: Dynamic DNS update exclude subnets:
1597753629: LIB: 6:   No subnet

Produits concernés

PowerStore, PowerStore 1000T, PowerStore 3000T, PowerStore 5000T, PowerStore 7000T, PowerStore 9000T
Propriétés de l’article
Numéro d’article: 000133035
Type d’article: Solution
Dernière modification: 06 Aug 2025
Version:  7
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