Variables d’environnement de restauration manquantes après le redémarrage dans InsightIQ 6.x.

Résumé: Certaines variables d’environnement critiques (par exemple, IAM_CPUS, RDP_MEMORY, etc.) peuvent être désactivées ou apparaître vides par intermittence après la mise à niveau de InsightIQ de la version 5.x vers la version 6.x. ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

La mise à niveau d’InsightIQ de la version 5.x vers la version 6.x ou lors de redémarrages sur une configuration 6.x, tels que ceux déclenchés par un arrêt ou un redémarrage du système, peut entraîner certaines variables d’environnement critiques (par exemple, IAM_CPUS, RDP_MEMORY) ne sont pas définis ou apparaissent vides par intermittence. 

Ce problème se manifeste généralement lors de l’exécution de scripts de mise à niveau (de versions 6.x antérieures vers ultérieures) ou de scripts au niveau du système. Les erreurs liées aux variables d’environnement manquantes s’affichent sur la console et les conteneurs de service InsightIQ ne parviennent pas à s’initialiser.

Des messages d’erreur tels que : 
WARN[0000] The "RDP_CPUS" variable is not set. Defaulting to a blank string.
WARN[0000] The "DC_MEMORY" variable is not set. Defaulting to a blank string.

Cause

Les systèmes mis à niveau de la version 5.x vers la version 6.x ont plusieurs appels d’exécution dans crontab Cela entraîne l’exécution simultanée des scripts lorsque le système s’affiche après le redémarrage. Cela provoque une condition de concurrence dans laquelle certaines variables d’environnement sont brusquement supprimées. Ce problème est résolu dans la version 6.1.0.

Résolution

Ouvrez un dossier d’incident si vous pensez rencontrer ce problème pour que le fichier soit mentionné dans la résolution. Cela permet de vérifier que vous rencontrez réellement ce problème, car il existe des problèmes similaires que le plan d’action ci-dessous ne traite pas.

Lors de l’ouverture d’un dossier, prenez les informations de l’article Isilon : Comment collecter les journaux InsightIQ (il peut être nécessaire de se connecter en tant qu’utilisateur enregistré au support Dell pour les consulter) et toute sortie PuTTY affichant l’erreur. 

  1. Téléchargez le restore-env-vars.tar.gz Ce lien hypertexte renvoie à un site Web extérieur à Dell Technologies..
  2. Décompressez le fichier à l’aide de tar xvzf restore-env-vars.tar.gz.
  3. cd restore-env-vars
  4. chmod 777 main.sh utils.sh
  5. ./main.sh - Cette opération restaure les variables d’environnement pour InsightIQ 6.x.
  6. Déconnectez-vous du terminal actuel, puis reconnectez-vous.
  7. Après avoir appliqué le correctif, procédez à la mise à niveau à partir de la version 6.x antérieure vers la version 6.x supérieure, ou avec des scripts système tels que system-shutdownsystem-reboot ou bash restart.sh pour redémarrer les services InsightIQ.

Produits

PowerScale InsightIQ
Propriétés de l’article
Numéro d’article: 000362058
Type d’article: Solution
Dernière modification: 09 Apr 2026
Version:  4
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.