Data Domain : Problème de mise à jour de firmware de disque sur DDOS 7.x | 8,0 | 8.1| 8.2 | 8.3.0.x
Résumé: Sur DDOS versions 7.10, 7.13, 8.0, 8.1, 8.2, 8.3.0.x, Data Domain (DD) sur lesquels les mises à jour du firmware de disque sont activées peuvent rencontrer des pannes de disque inattendues et fausses. Plus précisément, deux périphériques par groupe de disques (DG) peuvent passer à l’état d’échec en raison d’un problème de nombre de références de module RAID dans le noyau. Cela peut entraîner une instabilité du système et des risques potentiels pour la disponibilité des données. ...
Symptômes
- Deux appareils par groupe de périphériques (DG) passent de manière inattendue à l’état d’échec
- Toute tentative de mise en échec d’un troisième périphérique sur l’unité principale entraîne une panique du système (état Échec total)
- Excessive
kern.infoEntrées de log WARN - État du groupe de disques dégradé
- Dégradation notable des performances sur le DD
Systèmes concernés :
- Systèmes DD avec stockage externe exécutant les premières versions de DDOS 7.10 | 7,13 | 8,0 | 8.1 | 8.2 | 8.3.0.x
Cause
Au cours du processus de mise à jour du firmware de disque, la commande RAID check scan Peut s’exécuter plusieurs fois en fonction du nombre d’appareils dans le système. Chaque exécution augmente le nombre de références du module RAID dans le noyau Linux. Sur les versions de noyau 4.4 et 5.4 (utilisées dans DDOS 7.7, 7.10, 7.13, 8.0, 8.1, 8.2 et 8.3.0.x), ce nombre de références ne diminue pas. Si le nombre bascule à zéro, le noyau bloque l’accès RAID gendisk structures, ce qui fait que les appareils sont marqués comme illisibles et déplacés vers un état d’échec. Chaque DG ne tolère que deux appareils défaillants ; une troisième défaillance déclenche un fonctionnement inattendu du système sur l’unité principale (contrôleur).
Résolution
Un correctif permanent a été intégré dans les versions suivantes de DDOS :
- Versions de LTS :
- 7.10.1.70 || 7.13.1.30 || 8.3.1.0 (ou version ultérieure)
- Versions de fonctionnalités :
- >= 8.4.0.x
Solution de contournement :
- Si la mise à niveau n’est pas possible.
- À effectuer par le support technique Dell :
- Modifiez le script de mise à niveau du firmware de disque pour qu’il revienne immédiatement après l’exécution, ce qui réduit l’augmentation du nombre de références du module RAID.
- Clients : Effectuez une demande de service auprès du support technique Dell et consultez cet article de la base de connaissances (#000331892) pour accélérer la résolution.