メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能

SupportAssistAgent.exeによるメモリー使用率が高い

概要: この記事では、タスク マネージャーでメモリー使用率が高い(>90%)を引き起こすSupportAssistAgent.exeについて説明します。

この記事は次に適用されます:   この記事は次には適用されません: 

現象

対象製品:

  • ホームPC用SupportAssist

影響を受けるバージョン:

  • v3.13.x
  • v3.14.x

影響を受けるプラットフォーム:

  • Alienware
  • Gシリーズ
  • OptiPlex
  • Latitude
  • Inspiron
  • Precision Workstation
  • Vostro
  • XPS

一部のマシンのSupportAssist v3.13.xおよび3.14.xでは、メモリー使用率が高くなります。この現象が発生すると、タスク マネージャーにメモリー使用率 >が90%と表示されます。

これは、コンピューターのパフォーマンスに影響を与える可能性があります。また、コンピューターが応答を停止して画面が黒くなる場合もあります。

タスク マネージャー SupportAssistAgent.exeメモリー使用率が高いと表示される
図1: (英語のみ)タスク マネージャー SupportAssistAgent.exeメモリー使用率が高いと表示される

原因

IoT 接続は Microsoft Azure SDK を使用して行われ、メモリ リークが発生しています。

解決方法

この問題は、最新のリリースv4.0.3で解決されています。

  • 最新バージョンは自動的にアップグレードされます。または、SupportAssistユーザー インターフェイスを開いたときにアップグレードを求めるプロンプトが表示されます。
  • 手動でバージョンをアップグレードできます。詳細については、「 SupportAssist for Home PCの詳細を見る」を参照してください。

以下にリストされているプラットフォームは、SupportAssist v4.0.3に自動アップグレードできません。

一時的に除外されるプラットフォーム:

プラットフォーム
Dell G15 5530
Dell G16 7630
Inspiron 14 5440
Inspiron 14 5445
Inspiron 14 7440 2-in-1
Inspiron 15 3520
Inspiron 15 3530
Inspiron 16 5640
Inspiron 16 5645
Vostro 14 3430
Vostro 15 3530
Vostro 16 5640
Vostro 3420
Vostro 3520
注:これらのプラットフォームを使用しているユーザーは、次の手順に従ってアップグレードできます。

SupportAssist v4.0.3を手動でダウンロードしてインストールする手順:

  1. 最新の .net デスクトップ ランタイムをインストールする: https://dotnet.microsoft.com/download/dotnet/6.0 このハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。

.NET Desktop Runtime 6.0.29
図2:(英語のみ).NET Desktop Runtime 6.0.29

  1. システム タイプを見つけるには、Windowsの検索バーで 「システム情報 」を検索します。

システム情報
図3:(英語のみ)システム情報

  1. Dellダウンロード カタログから最新のSupportAssist.msi(SupportAssistx64-4.0.3.61632.msi)をダウンロードします。
  2. Dellダウンロード カタログから最新のSupportAssist .msp(SupportAssistx64-4.0.3.61632.msp)をダウンロードします。
  3. Cドライブにフォルダーを作成し、SAという名前を付けます。
  4. ダウンロードした .msi ファイルと .msp ファイルをCドライブのSAフォルダーにコピーします。
  5. 管理者としてコマンド プロンプトを開きます
    1. コマンド msiexec /i C:\SA\SupportAssistx64-4.0.0.61632.msi /qb /l*v と入力してEnterを押します。.msiのインストールが完了するまで待ちます。

インストール ウィンドウ.msi。
図4:(英語のみ)インストール ウィンドウ.msi。

  1. コマンド msiexec /p C:\SA\SupportAssistx64-4.0.3.61632.msp /qb /l*v と入力してEnterを押します。.msp のインストールが完了するのを待ちます。

.msp インストールウィンドウ
図5:(英語のみ).msp インストールウィンドウ

  1. [プログラム]に移動して、SupportAssistアプリケーションを開きます。

その他の情報

対象製品

Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Fixed Workstations, Mobile Workstations, SupportAssist for Home PCs
文書のプロパティ
文書番号: 000223371
文書の種類: Solution
最終更新: 30 5月 2024
バージョン:  5
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。