Домен даних: Користувач DD Boost показує статус блокування
요약: У цій статті описано проблему, коли користувач ddboost показує статус блокування в інтерфейсі користувача. Це призводить до збою резервного копіювання та скарг програми на відсутність зв'язку з сервером зберігання даних Data Domain. ...
증상
Як підтвердити
Єдиний спосіб виявити, що термін дії пароля закінчився або протягом 7 днів після закінчення терміну дії – це надіслати SSH до системи DD за допомогою користувача ddboost із програми резервного копіювання.
Таким чином, важко перевірити, що вік пароля близький до закінчення або закінчення терміну дії.
Приклад
ssh ddboost@"testdd.emc.com" Data Domain OS You are required to change your password immediately (password aged) Last login: Thu Apr 21 13:41:18 PDT 2016 from testavamar.emc.com on ssh WARNING: Your password has expired. You must change your password now and login again! Changing password for ddboost. (current) UNIX password:
Помічені проблеми
- Користувач ddboost має статус «заблоковано» у веб-інтерфейсі System Manager.
- Програми резервного копіювання, такі як Avamar, NetWorker і NetBackup, стикаються з помилками резервного копіювання DD
- Програма резервного копіювання скаржиться на відсутність зв'язку з сервером зберігання даних Domain
- Побачити цей статус можна у вкладці "DD Boost" або "Access -> Local Users" в лівому меню


원인
Першопричина
Основна причина блокування користувача ddboost полягає в тому, що термін дії пароля закінчився.
Причина
- Виконайте команду
# user password aging show
- Швидше за все, ви побачите, що для параметра «Максимальна кількість днів між змінами» встановлено значення 90
- Також на веб-інтерфейсі ви можете побачити це в розділі "Доступ -> Локальні користувачі (показано червоним на малюнку вище)

- Це пов'язано з тим, що після оновлення DDOS до 5.6 або вище максимальна кількість днів між змінами встановлюється за замовчуванням 90 днів
- Навіть якщо ви зміните термін старіння пароля на більше 90 днів, при наступних оновленнях (наприклад, з 6.0 до 6.1) він знову встановлюється на 90 днів за замовчуванням
해결
Тимчасовий
Коли користувача ddboost заблоковано:
-
Увійдіть у систему Data Domain як системний користувач (або будь-який інший користувач з ролями адміністратора)
-
Увімкніть користувач ddboost
# user enable <ddboost-user>
-
Переконайтеся, що користувач ddboost тепер увімкнено.
# user show list
Після того, як ви виконаєте вищезазначені дії, у вас знову повинен бути доступ і жодних подальших проблем протягом наступних 90 днів.
Резолюція
-
Встановіть на своєму боці нагадування про зміну пароля ddboost протягом кожних 90 днів, якщо ви хочете зберегти значення за замовчуванням у 90 днів.
(Пам'ятайте, що єдиний спосіб отримати попередження про зміну з DD - це якщо ви SSH до системи за допомогою користувача ddboost протягом 7 днів після закінчення терміну дії пароля)Це може бути непрактично, тому кращим рішенням буде:
-
Змініть значення «max-days-between-change» 90 на вище значення у вашій системі DD;
# user password aging set <affected ddboost user name> max-days-between-change 99999 Example # user password aging set ddboost_user_1 max-days-between-change 99999
# user password aging show
Наведене вище значення означає, що ви не зобов'язані змінювати пароль ddboost ніколи (273 роки, якщо бути точним!).
Однак ви можете змінити на будь-який час, який вам подобається.
Додаткова інформація
Якщо ви все ще не можете отримати доступ або створити резервну копію до DD за допомогою користувача ddboost після вищезазначених дій, ви можете зіткнутися з тайм-аутом через кілька спроб резервної програми отримати доступ до DD, і тому обліковий запис ddboost залишатиметься заблокованим протягом деякого часу (залежно від того, скільки невдалих спроб входу). Може знадобитися зупинити служби додатків резервного копіювання, які зв'язуються з ДД, щоб переконатися, що тайм-аут не скидається безперервно.
Зверніться до служби підтримки Dell і відкрийте запит до служби підтримки доменів даних, якщо після виконання дій, описаних у цій статті, у вас не зникнуть проблеми.
추가 정보
Цей контент перекладено іншими мовами:
- https://downloads.dell.com/TranslatedPDF/ES_KB520213.pdf
- https://downloads.dell.com/TranslatedPDF/DE_KB520213.pdf
- https://downloads.dell.com/TranslatedPDF/FR_KB520213.pdf
- https://downloads.dell.com/TranslatedPDF/IT_KB520213.pdf
- https://downloads.dell.com/TranslatedPDF/JA_KB520213.pdf
- https://downloads.dell.com/TranslatedPDF/KO_KB520213.pdf
Деталі загартовування користувача
| Опис | Рекомендація щодо загартовування |
|---|---|
| Змініть пароль за умовчанням. | Увійдіть як сисадмін і запустіть # user change password |
| Налаштуйте часту ротацію паролів відповідно до політики паролів компанії. | Дотримуйтесь політики паролів компанії, щоб встановити політику старіння пароля за замовчуванням.# user password aging option set |
| Налаштуйте політику надійних паролів. | Встановіть політику надійності пароля користувача:# user password strength setРекомендації щодо пароля:
|
| Різні вимоги до старіння пароля | DD рекомендує опцію старіння пароля користувача CLI. За замовчуванням політика паролів пом'якшена для зворотної сумісності. Клієнт може використовувати інтерфейс користувача або CLI, щоб змінити конфігурацію пароля таким чином, щоб вона була більш обмеженою та відповідала вимогам старіння.
|
| Різні вимоги до надійності паролів | DD підтримує всеосяжну політику паролів і рекомендує використовувати CLI або UI для посилення пароля. Встановіть або змініть характеристики та складність політики пароля облікового запису на все, що потрібно в коді програми. Перегляньте політику паролів, щоб дізнатися більше про вимоги.
|