OpenShift 가상화: VM에 "핫 플러깅 가능" 옵션이 활성화된 디스크가 있는 경우 VM 클론 생성 실패
요약: OpenShift 가상화 제한 사항으로 인해 "핫 플러깅 가능" 옵션이 활성화된 디스크가 있는 경우 VM을 복제할 수 없습니다.
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
VM에 "핫 플러깅 가능" 옵션이 활성화된 디스크가 있는 경우 VM 클론이 실패합니다.
새로 복제된 VM은 "WaitingForVolumeBinding" 상태로 유지됩니다.
새로 복제된 VM은 "WaitingForVolumeBinding" 상태로 유지됩니다.
VM "핫 플러깅 가능" 옵션은 다음과 같은 경우에 활성화됩니다.
- 사용자는 인터페이스 유형이 "SCSI"인 새 디스크(기존 PVC에서)를 실행 중인 기존 VM에 추가합니다.
- 사용자는 YAML을 통해 VM을 생성하고 "hotpluggable: true"를 명시적으로 설정합니다.
원인
이는 OpenShift 가상화 제한 사항입니다.
해결
VM 클론 작업 전에 "핫 플러깅 가능" 옵션을 비활성화합니다.
비활성화하는 두 가지 옵션:
- VM의 YAML을 편집하고 디스크에 대해 "hotpluggable: false"를 명시적으로 설정합니다.
- OpenShift 가상화 UI에서 "핫플러그" 디스크를 선택하고 "Make persistent" 버튼을 클릭합니다.
예:
해당 제품
APEX Cloud Platform for Red Hat OpenShift문서 속성
문서 번호: 000217670
문서 유형: Solution
마지막 수정 시간: 18 9월 2026
버전: 4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.