오픈시프트: 연결이 끊긴 클러스터에 OperatorHub가 구성된 경우 노드 제거에 실패함
요약: 연결이 끊긴 환경(제한된 네트워크에 있거나 인터넷 연결이 없는 클러스터)에서 사용자가 Dell APEX Cloud Platform 웹 콘솔 플러그인을 통해 노드를 제거하려고 하면 "노드에 베어 포드가 있는지 확인" 단계에서 프로세스가 실패합니다.
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
Red Hat OpenShift 웹 콘솔에 로그인하고 인벤토리 탭으로 이동하여 작업자 노드 하나를 선택하고 작업 → 작업자 노드 제거를 클릭한 다음 제거 버튼을 클릭하여 작업을 확인합니다.
제거 프로세스는 "노드에 베어 포드가 있는지 확인" 단계에서 실패하고 "드레이닝 노드 중에 베어 포드 openshift-marketplace/redhat-operator-index-wltgx를 자동으로 마이그레이션할 수 없습니다. 수동으로 처리하십시오"라는 오류 설명이 표시됩니다.

제거 프로세스는 "노드에 베어 포드가 있는지 확인" 단계에서 실패하고 "드레이닝 노드 중에 베어 포드 openshift-marketplace/redhat-operator-index-wltgx를 자동으로 마이그레이션할 수 없습니다. 수동으로 처리하십시오"라는 오류 설명이 표시됩니다.

원인
노드 제거 프로세스는 실제 제거가 시작되기 전에 먼저 몇 가지 사전 검사를 수행합니다. 사전 검사에는 클러스터에 상주하는 베어 포드가 있는지 여부 검증이 포함됩니다. 이러한 베어 포드가 있는 경우 사용자가 수동으로 처리해야 합니다.
제한된 네트워크에 있거나 인터넷 연결이 없는 클러스터의 경우 사용자가 SolVe 절차 "Dell APEX Cloud Platform for Red Hat OpenShift - OperatorHub 구성 절차" 섹션 3 "연결이 끊긴 클러스터에서 OperatorHub에 대한 CatalogSource 및 ImageContentSourcePolicy 구성"에 따라 OperatorHub를 구성하면 포드 "redhat-operator-index-wltgx"가 클러스터로 유입되고 노드 제거 사전 검사 오류가 발생합니다.
제한된 네트워크에 있거나 인터넷 연결이 없는 클러스터의 경우 사용자가 SolVe 절차 "Dell APEX Cloud Platform for Red Hat OpenShift - OperatorHub 구성 절차" 섹션 3 "연결이 끊긴 클러스터에서 OperatorHub에 대한 CatalogSource 및 ImageContentSourcePolicy 구성"에 따라 OperatorHub를 구성하면 포드 "redhat-operator-index-wltgx"가 클러스터로 유입되고 노드 제거 사전 검사 오류가 발생합니다.
해결
1. 포드를 다른 노드로 강제로 마이그레이션하려면 사용자가 노드를 수동으로 드레이닝해야 합니다.
참고: 다음 명령을 수행하기 전에 이 노드에서 고객 소유의 워크로드/데이터를 적절히 처리하십시오.
2. 노드 제거를 다시 시도하십시오.
참고: 다음 명령을 수행하기 전에 이 노드에서 고객 소유의 워크로드/데이터를 적절히 처리하십시오.
oc adm cordon <target-hostname-to-remove> oc adm drain <target-hostname-to-remove> --ignore-daemonsets --delete-emptydir-data --force oc adm uncordon <target-hostname-to-remove>
2. 노드 제거를 다시 시도하십시오.
해당 제품
APEX Cloud Platform for Red Hat OpenShift문서 속성
문서 번호: 000217681
문서 유형: Solution
마지막 수정 시간: 18 9월 2026
버전: 4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.