OpenShift Virtualization: Kan VM-snapshot niet maken van de OpenShift Virtualization UI.

Samenvatting: VM-snapshot maken via OpenShift Virtualisatie-ui mislukt als er IO wordt uitgevoerd in de VM in OCP-cluster.

Dit artikel is van toepassing op Dit artikel is niet van toepassing op Dit artikel is niet gebonden aan een specifiek product. Niet alle productversies worden in dit artikel vermeld.

Symptomen

VM-snapshot maken via OpenShift Virtualisatie-UI mislukt.
image.png

Bij het controleren van logboeken van virt-handler pod (openshift-cnv namespace), worden fouten weergegeven zoals hieronder:
2023-08-14T02:23:33.722372232Z {"component":"virt-handler","kind":"","level":"error","msg":"Kan VMI niet bevriezen","name":"rhel9-vm-http-block",
"namespace":"rhel-vm","pos":"lifecycle.go:124","reason":"serverfout.
opdracht Freeze failed: \"LibvirtError(Code=1, Domain=10, Message='internal error: unable to execute QEMU agent command 'guest-fsfreeze-freeze':
failed to open /zoner/sda: Permission denied')\"","timestamp":"2023-08-14T02:23:33.722321Z","uid":"c6894dc7-f29c-43e7-9817-3b12643040d1"}

Oorzaak

Maak een VM via OpenShift Virtualization. Het koppelpunt van de gemaakte LUN is niet gelabeld als vertrouwd. Dus tijdens het VM-snapshotproces slaagt de QEMU agent er niet in om het koppelpunt te openen (in deze KB is het koppelpunt /zoner/sda) en wordt de toestemming geweigerd terwijl het probeert om fsfreeze uit te voeren.

Oplossing

Bij de onderstaande resolutiestappen wordt aangenomen dat "/zoner/sda" het koppelpunt is.

Gebruik de opdracht "df -h" en controleer in uw foutenlogboeken of u het werkelijke koppelpunt voor foutrapportage van uw VM kunt bevestigen.


1. Controleer of de SELinux-context van het koppelpunt "unlabeled_t" weergeeft met de onderstaande opdracht:

# ls -lZd /zoner/sda/


2. Als "unlabeled_t" wordt weergegeven, zijn er twee opties om dit op te lossen.

  • Optie 1: Om de QEMU-agent in staat te stellen niet-gelabelde bestanden te lezen.
# setsebool -P virt_qemu_ga_read_nonsecurity_files 1

 

  • Optie 2: Om het koppelpunt te labelen.
# restorecon -v /zoner/sda/

 

Getroffen producten

APEX Cloud Platform for Red Hat OpenShift
Artikeleigenschappen
Artikelnummer: 000217270
Artikeltype: Solution
Laatst aangepast: 18 sep. 2026
Versie:  4
Vind antwoorden op uw vragen via andere Dell gebruikers
Support Services
Controleer of uw apparaat wordt gedekt door Support Services.