Avamar: O serviço Downloader não é compatível com autenticação de proxy

Resumo: O Avamar Downloader não funciona corretamente por meio de um servidor proxy que requer autenticação.

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

O Avamar Downloader Service (ADS) é instalado e configurado para usar um servidor proxy para acessar a Internet.

A tela "Opções da Internet" do computador pessoal também está configurada para usar o proxy. Ele permite que os navegadores da Web acessem a Internet através da porta padrão 8080.  

Se o ADS verificar se há atualizações de arquivo, um arquivo manifest.xml será gravado no repositório local do ADS. Nenhum erro é relatado no log do ADS e o ADS acredita que baixou com êxito o arquivo manifest.xml.  

No entanto, o conteúdo do arquivo é inválido, pois eles foram substituídos pelo seguinte texto:

<HEAD><TITLE>Proxy Authorization Required</TITLE></HEAD> <BODY BGCOLOR="white" FGCOLOR="black"><H1>Proxy Authorization Required</H1><HR> <FONT FACE="Helvetica,Arial"><B> Description: Authorization is required for access to this proxy</B></FONT> <HR> <!-- default "Proxy Authorization Required" response (407) --> </BODY>
Parece haver um problema com a autenticação do Avamar Downloader Server no proxy.
Os navegadores da Web regulares podem fazer download corretamente do manifesto do Avamar.xml. 
O servidor proxy exige que os clientes se autentiquem nele usando credenciais válidas de usuário de domínio.

Causa

O Avamar Downloader Service não é compatível com autenticação de proxy.  

Resolução

O Avamar Downloader Service é incompatível com proxies que exigem autenticação. 

Uma solução temporária pode ser possível se o servidor proxy puder excluir clients do mecanismo de autenticação com base no endereço MAC ou IP. Trabalhe com os administradores de proxy para determinar se esse recurso está disponível.

Mais informações

Local típico do repositório do Avamar
Downloader ServiceC:\Arquivos de Programas\EMC\Avamar Downloader Service\repository

Local típico para logs
do Avamar Downloader ServiceC:\Arquivos de Programas\EMC\Avamar Downloader Service\var\log\AvamarDownloaderService.log

O processo CheckManifestThreadProc é iniciado. Ele é concluído sem erros ou avisos relatados.
14/10/2013 09:27:45 [4436] CheckManifestThreadProc started
14/10/2013 09:27:45 [4436] curlFTPFetchFile(url=<link>,filename=C:\Program Files\EMC\Avamar Downloader Service\repository\manifest.xml~,checksum=,size=322)
14/10/2013 09:27:45 [4436] curlFTPFetchFile completed(url=<link>,filename=C:\Program Files\EMC\Avamar Downloader Service\repository\manifest.xml~,checksum=,bytes read=322)
14/10/2013 09:27:45 [4436] SendFile(filename=C:\Program Files\EMC\Avamar Downloader Service\repository\manifest.xml,checksum=,hostname=avamar.customer.com,size=322)
14/10/2013 09:27:50 [4436] SendFile completed(filename=C:\Program Files\EMC\Avamar Downloader Service\repository\manifest.xml,checksum=,hostname=avamar.customer.com,bytes sent=322)
14/10/2013 09:27:50 [4436] CheckManifestThreadProc finished

Produtos afetados

Avamar

Produtos

Avamar
Propriedades do artigo
Número do artigo: 000164577
Tipo de artigo: Solution
Último modificado: 16 dez. 2025
Versão:  7
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.