ECS: Erro 12175 do GeoDrive – O aplicativo apresentou um erro interno ao carregar as bibliotecas SSL
Resumo: GeoDrive - Erro do ECS - 12175 - Erro ao carregar as bibliotecas SSL | O aplicativo apresentou um erro interno ao carregar as bibliotecas SSL | A instalação está ausente.
Sintomas
O cliente relatou 12175 - O aplicativo apresentou um erro interno ao carregar as bibliotecas SSL.
A solução é relatada no Guia do usuário do Dell EMC® GeoDrive™ for Windows versão 2.0 NOTA:
antes de iniciar qualquer investigação, verifique os "Protocolos HTTPS permitidos" nas configurações avançadas de conexão de hosts.
Às vezes, a mesma mensagem de erro "O aplicativo apresentou um erro interno ao carregar as bibliotecas SSL" é exibida. Isso pode acontecer quando "SSL 2.0" e "SSL 3.0" são verificados nas configurações avançadas de conexão dos hosts.
Essas configurações não são ativadas por padrão, mas podem ter sido ativadas por engano.
Para verificar as configurações:
- Clique em "Hosts" na barra superior
- Escolha seu host e clique em "Editar"
- Escolha a guia "Avançado"
A figura abaixo mostra a configuração padrão para "SSL 2.0" e "SSL 3.0" como não marcadas de seleção.
Se ele estiver marcado, tente desativar "SSL 2.0" e "SSL 3.0" desmarcando-o e teste a conexão novamente.
Instalando o certificado
do servidor em nuvemSe uma mensagem de erro de segurança 12175 for recebida informando: "A função não conhece a autoridade de certificação que gerou o certificado do servidor", instale o certificado do servidor no client GeoDrive da seguinte maneira:
1. Depois de clicar em "Testar", o GeoDrive exibe uma mensagem de erro de segurança que também fornece os detalhes do certificado.
2. Verifique se o nome do host é igual ao nome fornecido pelo provedor de serviços. Além disso, o campo host/IP é inserido durante a configuração do servidor (consulte a Tabela 3 na página 11). Caso contrário, confirme o nome correto com seu provedor de serviços antes de continuar. Se necessário, exclua o nome de host incorreto, digite o nome correto no campo Host/IP, clique em "Add" e, em seguida, clique em "Test".
3. Se uma caixa de diálogo de êxito for exibida, esse procedimento será concluído. A conectividade com a nuvem é indicada com um ícone verde na página principal do GeoDrive.
4. Se a mesma mensagem de erro for recebida novamente, clique em Instalar. O GeoDrive instala o certificado SSL em seu computador local, e uma mensagem de sucesso é exibida.
5. Clique em OK. Uma conexão segura com o servidor é indicada com um ícone verde na página principal do GeoDrive.
Em um Windows 2016 Server, nenhuma opção de instalação de clique é mostrada:
Causa
No Windows 2016, encontra-se a função de fortalecimento do servidor no conjunto de registro em:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Cryptography\Configuration\SSL\00010002
Devido a uma entrada já existente, o software solicita "outra" instalação de chave. Porque ele já está lá:
Resolução
Em instalações regulares, a chave do Registro na função de proteção do servidor não está lá:
Portanto, a solução é encontrar a chave abaixo no registro:
"HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Cryptography\Configuration\SSL\00010002" e excluí-la (ou renomeá-la). Isso corrige o problema. Agora, o certificado pode ser instalado no servidor afetado usando um certificado SSL:
Mais informações
Ver: Capturando logs
WinHTTPOs logs WinHTTP podem ser usados para ajudar a solucionar problemas de aplicativos WSDAPI. Isso é útil quando a troca de metadados falha ou quando a negociação SSL/TLS falha.
Este procedimento mostra como capturar logs WinHTTP no computador cliente. O aplicativo cliente baseado em WSDAPI não deve estar em execução quando o log está habilitado. Se o aplicativo cliente estiver em execução quando o log estiver habilitado, o cliente e o computador deverão ser reiniciados antes do WS-Discovery. O tráfego de troca de metadados é exibido nos logs WinHTTP.
Para capturar logs WinHTTP.
- Abra uma janela de prompt de comando elevada no computador client.
- Execute o seguinte comando: netsh winhttp set tracing trace-file-prefix="C:\Temp\dpws" level=verbose format=ansi state=enabled max-trace-file-size=1073741824
- Esse comando ativa o log WinHTTP. Todos os arquivos de log são armazenados no diretório C:\Temp e os nomes de arquivo começam com o prefixo dpws. No máximo 1 GB de arquivos de log serão armazenados.
- Se o processo usando WinHTTP no client já estiver em execução, reinicie o computador. Por exemplo, se as APIs de Descoberta de Função estiverem sendo usadas, o computador deverá ser reiniciado. As APIs de detecção de função chamam WinHTTP de dentro de um host de serviço, que pode já ter sido iniciado quando o rastreamento foi habilitado.
- Inicie o aplicativo cliente baseado em WSDAPI. O aplicativo que está sendo está sendo depurado ou o WSD Debug Client pode ser usado.
- Reproduza a falha do aplicativo.
- Encerre o aplicativo cliente baseado em WSDAPI.
- Se o processo usando WinHTTP não for encerrado com o aplicativo cliente, reinicie o computador. Por exemplo, se as APIs de Descoberta de Função estiverem sendo usadas, o computador deverá ser reiniciado.
- Execute o seguinte comando: netsh winhttp set tracing state=disabled
- Esse comando desativa o log WinHTTP.
- Inspecione os logs do DPWS em C:\Temp e verifique se as solicitações e mensagens necessárias foram enviadas.
- Se a comunicação de canal seguro (HTTPS) estiver sendo usada, verifique se há falhas de SSL/TLS.
Depois que os logs WinHTTP forem capturados, os logs poderão ser examinados para procurar a causa de uma falha no aplicativo WSDAPI. O editor de texto usado para exibir esses logs deve ser executado como Administrador. Para obter mais informações, consulte Usando o log WinHTTP para verificar se obtém tráfego.