Data Protection Advisor (DPA): DPA agenta se nepodařilo zaregistrovat na aplikační server s chybou exception.name_conflict
Resumo: DPA agenta se nepodaří zaregistrovat na aplikační server s chybou exception.name_conflict
Este artigo aplica-se a
Este artigo não se aplica a
Este artigo não está vinculado a nenhum produto específico.
Nem todas as versões do produto estão identificadas neste artigo.
Sintomas
Registrace nového nainstalovaného agenta DPA na aplikační server DPA se nezdařila. V rámci dpaagent. log signalizuje následující chyba, že registrace selhala kvůli konfliktům názvů:
Výše uvedená chyba však neposkytuje přesný název pro konflikt, a to i s nízkou úrovní ladění programu Agent.
Chyba < >
< id > Exception.name_conflict </id >
< Zpráva > již existuje alias se stejným názvem. Zvolte jiný název </Message >
< položka Name = "typ" > alias </entry >
</Error >
Err 18330,18330 20210304:210609 agent. config – initAgentConfig (): Failed to register agent with the server. Čeká se na opakování...
< id > Exception.name_conflict </id >
< Zpráva > již existuje alias se stejným názvem. Zvolte jiný název </Message >
< položka Name = "typ" > alias </entry >
</Error >
Err 18330,18330 20210304:210609 agent. config – initAgentConfig (): Failed to register agent with the server. Čeká se na opakování...
Výše uvedená chyba však neposkytuje přesný název pro konflikt, a to i s nízkou úrovní ladění programu Agent.
Causa
Selhání registrace agenta je způsobeno konfliktem názvů, jak je uvedeno v protokolu dpaagent. Jakmile dojde k odstranění názvu hostitele, který způsobuje konflikt, je možné, že se agent úspěšně zaregistruje na aplikační server DPA.
Resolução
Název konfliktu nebyl nalezen v protokolu dpaagent, a to ani s nízkou úrovní ladění povoleno, protože aplikační server DPA tyto informace sleduje. Chcete-li zjistit název konfliktu a vyřešit problém, postupujte podle následujících kroků:
Další podrobnosti a informace vám sdělí tým technické podpory společnosti Dell EMC.
- Přihlaste se k aplikačnímu serveru DPA a přejděte na server. log v části < DPA Install dir >/Services/Logs/.
- V nástroji Server. log vyhledejte položku "uzel již nalezen". Mělo by se zobrazit něco podobného jako v:
2021-03-05 09:54: Chyba 53114 [com. EMC. Apollo. Command. Node. UpdateNodeCommandBean] (http-/0.0.0.0:9002-3) uzel se již našel pomocí New aliasu XXXXXX stávající název nodeElement: YYYYYY
09:54:53114 Error [org. JBoss. as. EJB3] (http-/0.0.0.0:9002-3) javax. EJB. EJBTransactionRolledbackException: Alias se stejným názvem již existuje. Zvolte jiný název (exception.name_conflict)
09:54:53114 Error [org. JBoss. as. EJB3] (http-/0.0.0.0:9002-3) javax. EJB. EJBTransactionRolledbackException: Alias se stejným názvem již existuje. Zvolte jiný název (exception.name_conflict)
- Přejděte do DPA grafického rozhraní > Inventory > Library > Hosts a vyhledejte YYYYYY pro hostitele.
- Vyberte YYYYYY vlastnosti hostitele v části > aliasy a hledejte konflikt názvů XXXXXX.
- V případě problému si vytvořte kopii všech názvů aliasu.
- Vyberte možnost název zástupného názvu XXXXXX a klikněte na možnost Delete (odstranit).
- Klikněte na možnost Použít a poté na možnost OK.
- Restartujte agenta DPA, který se nepodařilo zaregistrovat, a měl by být schopen zaregistrovat se na DPA aplikační server.
Další podrobnosti a informace vám sdělí tým technické podpory společnosti Dell EMC.
Produtos afetados
Data Protection AdvisorPropriedades do artigo
Número do artigo: 000183846
Tipo de artigo: Solution
Último modificado: 23 jul. 2021
Versão: 4
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.