O backup do Oracle do Windows falha com "ORA-01031: Privilégios insuficientes" quando um usuário tem apenas uma função SYSBACKUP.

Resumo: Avamar: O backup do Oracle do Windows falha com "ORA-01031: Privilégios insuficientes" quando apenas o privilégio SYSBACKUP é concedido a um usuário.

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

O backup do Oracle do Windows falha com o erro "ORA-01031: Privilégios insuficientes" quando apenas o privilégio SYSBACKUP é concedido a um usuário.

 

O log avoracle indica que o teste do usuário é usado para se conectar a um banco de dados:

++++++++++++++++++++++++++++++++++++
avoracle Info : RMAN is connecting to the Oracle DB as the DB user 'test'
avoracle Info : RMAN=c:\work\windows.x64_193000_db_home\bin/rman
avoracle Info : RMAN=c:\work\windows.x64_193000_db_home\bin/rman
avoracle Error : Snapup of ORCL aborted due to rman terminated abnormally - check the logs
++++++++++++++++++++++++++++++++++++

O registo do Recovery Manager (RMAN) indica que o utilizador não tem privilégios suficientes e não consegue estabelecer a ligação:

++++++++++++++++++++++++++++++++++++
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
ORA-01031: insufficient privileges

Recovery Manager complete.
++++++++++++++++++++++++++++++++++++

 

Causa

Isto ocorre devido a uma falha de software no plug-in Avamar Windows avoracle.

 

Resolução

Atualizar o Servidor Avamar para a versão 19.8.100-83 ou posterior. A correção é incorporada no Avamar 19.8 e versões posteriores do software.

 

Vídeos

N/A
Propriedades do artigo
Número do artigo: 000202697
Tipo de artigo: Solution
Último modificado: 11 jun. 2024
Versão:  7
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.