Dell Unity: Após o upgrade, a política de hot spare para o pool tradicional não está sendo atendida e a mensagem de advertência é observada. (Corrigível pelo usuário)

Resumo: Depois de fazer upgrade do código 5.2.1.0.5.013 ou posterior, o Unisphere relata uma mensagem de advertência sobre a política de unidade sobressalente.

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

Depois de fazer upgrade do código OE do array, o Unisphere relata uma mensagem de advertência sobre a política de hot spare.

Mensagem de advertência da política de hot spare

Nas coletas de dados, você pode ver instâncias da violação sendo denunciadas:

TRiiAGE_full_ECOM.txt:

A       10/26/24 19:03:20.000 isSparePolicyViolated     cemtracer_health INFO: Hot spare policy of DiskGroupID=dg_24 is violated. [C4CB_StorageSystemHealth.cpp:875]
A       10/28/24 17:51:26.000 isSparePolicyViolated     cemtracer_health INFO: Hot spare policy of DiskGroupID=dg_24 is violated. [C4CB_StorageSystemHealth.cpp:875]

TRiiAGE_full_SPlogs.txt:

B       10/19/24 02:14:26.981 CoreProvisionSvc   5200a6 [ERROR] Audit: The spare drive policy for traditional pools is not being met. Add a minimum of 1 1.8 TB SAS 10K drives to the system.
B       10/21/24 17:42:11.020 CoreProvisionSvc   5200a7 [INFO] Audit: The system has 1.8 TB SAS 10K drives, which is enough to meet the spare drive policy for traditional pools.

SPx/EMC/CEM/log/cemtracer.log:

A 10/26/24 07:36:39.000 isSparePolicyViolated cemtracer_health INFO: Hot spare policy of DiskGroupID=dg_24 is violated. [C4CB_StorageSystemHealth.cpp:875]
A 10/28/24 08:07:03.000 isSparePolicyViolated cemtracer_health INFO: Hot spare policy of DiskGroupID=dg_24 is violated. [C4CB_StorageSystemHealth.cpp:875]

SPx\EMC\CEM\log\cemtracer_health_services.log:

03 Nov 2024 12:22:34  - [Health] INFO - {0:672637:49317478}[21732|4329|e5fffb40][isSparePolicyViolated @ ../../../components/providers/osls/Health/src/C4CB_StorageSystemHealth.cpp:875] Hot spare policy of DiskGroupID=dg_24 is violated.
03 Nov 2024 12:23:34  - [Health] INFO - {0:672696:799062102}[21732|4329|e5fffb40][isSparePolicyViolated @ ../../../components/providers/osls/Health/src/C4CB_StorageSystemHealth.cpp:875] Hot spare policy of DiskGroupID=dg_24 is violated.
03 Nov 2024 12:28:51  - [Health] INFO - {0:673013:665903359}[21732|718|e59ffb40][isSparePolicyViolated @ ../../../components/providers/osls/Health/src/C4CB_StorageSystemHealth.cpp:875] Hot spare policy of DiskGroupID=dg_24 is violated.
03 Nov 2024 12:28:51  - [Health] INFO - {0:673013:814940102}[21732|4329|e5fffb40][isSparePolicyViolated @ ../../../components/providers/osls/Health/src/C4CB_StorageSystemHealth.cpp:875] Hot spare policy of DiskGroupID=dg_24 is violated.

Causa

As mensagens de advertência serão relatadas no pool tradicional quando a política de hot spare não estiver sendo atendida.  De acordo com a Política de hot spare, deve haver 1 unidade sobressalente para cada 31 unidades do mesmo tipo, capacidade e velocidade rotacional ou tipo de Flash.

Em determinados cenários, observa-se que a mensagem de advertência só é exibida após um upgrade. Nesses cenários, foi uma unidade do sistema (disco DPE 0 até o disco DPE 3) que apresentou falha no passado. As unidades do sistema não podem ser hot spare. Quando uma unidade do sistema falha e é substituída, a contagem de hot spare fica inativa em uma unidade.

Resolução

Primeiro, determine se há unidades desvinculadas disponíveis (exceto unidades do sistema Disco DPE 0 até DPE Disco 3):

  • No Unisphere, navegue até Configurações >Unidades de configuração> de armazenamento.
  • Procure na coluna "Unconfigured Available" para ver se há unidades disponíveis para o tipo de unidade específico.
  • Se houver unidades disponíveis, tente reiniciar os serviços de gerenciamento.
  • Consulte o KBA 000019458 Dell Unity: Como reiniciar ou fazer failover dos serviços de gerenciamento (corrigível pelo usuário)
  • Se houver unidades na coluna "Unconfigured Available" e reiniciar os serviços de gerenciamento não resolver a mensagem de aviso, entre em contato com o suporte do Unity para obter mais assistência.

Verifique o histórico de falhas da unidade para determinar se uma unidade do sistema (disco DPE 0 até o disco DPE 3) falhou no passado,

  • Na página Unidadesdas propriedades> do pool, verifique se alguma das unidades do sistema faz parte do pool. As primeiras 4 unidades de cada sistema Dell Unity são chamadas de unidades do sistema (do disco DPE 0 até o disco DPE 3). O Dell Unity OE também usa a capacidade dessas 4 unidades para armazenar cópias de informações de configuração e outros dados críticos do sistema.
  • Exemplo: Os discos DPE 0 a 2 fazem parte de um pool enquanto o disco DPE 3 está mostrando não vinculado. Analise substituições de disco anteriores para verificar se o disco DPE 3 foi substituído. 
    • Se a unidade do sistema falhou no passado e ainda estiver em um estado desvinculado, existe a possibilidade de que essa seja a causa da mensagem de aviso, pois deixará a unidade de política de hot spare 1 curta. 
    • Quando uma unidade do sistema falha, os dados do usuário são copiados para um hot spare do mesmo tipo.  Quando a unidade do sistema é substituída, o OE não permite que a unidade do sistema se torne um hot spare. O sistema Unity não copiará automaticamente os dados do usuário para a unidade do sistema. Para recuperar uma unidade hot spare, o suporte do Unity precisará ser acionado para copiar manualmente os dados do usuário de volta para a unidade do sistema.
  • Consulte o Dell EMC Unity: Guia de práticas recomendadas , página 17, seção 2.2.4 "Unidades do sistema" para obter mais detalhes.
  • Se o problema corresponder ao cenário da unidade do sistema, há duas opções para resolver a mensagem de aviso.
    • Opção 1: Adicione mais unidades ao array para permitir outro hot spare
    • Opção 2: Copie os dados do usuário do hot spare original para a nova unidade do sistema. Se essa for a opção, entre em contato com o suporte e consulte este artigo da base de conhecimento com sua opção.

Produtos afetados

Dell EMC Unity, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
Propriedades do artigo
Número do artigo: 000207645
Tipo de artigo: Solution
Último modificado: 22 jan. 2026
Versão:  9
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.