NVP vProxy: Los respaldos de VM SQL (msvmappagent) fallan con el mensaje "Error recibido de vProxy"-400: Falta el nombre de usuario de la VM en la solicitud. ""
Resumo: Se produce un error en un respaldo de máquina virtual (VM) de Microsoft SQL realizado mediante el dispositivo vProxy de NetWorker VMware Protection (NVP). En el registro de acciones de respaldo de NetWorker, se muestra "Error recibido de vProxy ="-400: Falta el nombre de usuario de la VM en la solicitud". ” ...
Este artigo aplica-se a
Este artigo não se aplica a
Este artigo não está vinculado a nenhum produto específico.
Nem todas as versões do produto estão identificadas neste artigo.
Sintomas
- Un respaldo de Microsoft SQL Server se configura mediante el dispositivo vProxy de NetWorker VMware Protection (NVP).
- La acción de respaldo de la política de protección se configura con la opción "Application Consistency" habilitada para realizar respaldos coherentes con las aplicaciones de SQL (MSVMAPPAGENT).
- El respaldo falla y se informa el siguiente error en los registros de acciones de respaldo:
- El vProxy de
/opt/emc/vproxy/runtime/logs/vbackup/vbackupd-engine.logmuestra mensajes de error similares:
vproxy02:~ # tail -n 15 /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-engine.log
YYYY-MM-DDTHH:mm:SSZ NOTICE: f07a24dd-e7c3-48e5-8f89-3053c3249a65:vm-1013:win-sql02: Backup session is exiting
YYYY-MM-DDTHH:mm:SSZ TRACE: Resource Update f07a24dd-e7c3-48e5-8f89-3053c3249a65:externalId=vcsa.amer.lan:vm-1013:state=Success:deletable=true:updatable=true.
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4881: Handling action 'GetLog' for 'f07a24dd-e7c3-48e5-8f89-3053c3249a65' ...
YYYY-MM-DDTHH:mm:SSZ TRACE: Request #4881: Reply sent successfully for 'GetLog'.
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4882: Handling action 'DeleteSession' for 'f07a24dd-e7c3-48e5-8f89-3053c3249a65' ...
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4882: Deleting logfiles of session 'f07a24dd-e7c3-48e5-8f89-3053c3249a65'...
YYYY-MM-DDTHH:mm:SSZ TRACE: Request #4882: Deleting log file '/opt/emc/vproxy/runtime/logs/vbackupd/BackupVmSessions-f07a24dd-e7c3-48e5-8f89-3053c3249a65.log' of session 'f07a24dd-e7c3-48e5-8f89-3053c3249a65'...
YYYY-MM-DDTHH:mm:SSZ INFO: File '/opt/emc/vproxy/runtime/logs/vbackupd/BackupVmSessions-f07a24dd-e7c3-48e5-8f89-3053c3249a65.log' is moved to '/opt/emc/vproxy/runtime/logs/recycle/vbackupd/20240112_1/BackupVmSessions-f07a24dd-e7c3-48e5-8f89-3053c3249a65.log'.
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4882: Deleted log file '/opt/emc/vproxy/runtime/logs/vbackupd/BackupVmSessions-f07a24dd-e7c3-48e5-8f89-3053c3249a65.log'.
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4882: Deleted resource: vcsa.amer.lan:vm-1013 - f07a24dd-e7c3-48e5-8f89-3053c3249a65.
YYYY-MM-DDTHH:mm:SSZ TRACE: Request #4882: Reply sent successfully for 'DeleteSession'.
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4884: Handling action 'StartSession' for 'BackupVmSessions' ...
YYYY-MM-DDTHH:mm:SSZ ERROR: Request #4884: Request is missing the VM user name.
YYYY-MM-DDTHH:mm:SSZ ERROR: Request #4884: Failed to create resource: -400: Request is missing the VM user name.
YYYY-MM-DDTHH:mm:SSZ TRACE: Request #4884: Reply sent successfully for 'StartSession'.
- Los respaldos de imágenes de la VM que no utilizan "Application Consistency" se completan correctamente.
Causa
A la acción de respaldo en la política de protección de NetWorker le falta el inicio de sesión del usuario de la instancia de SQL en los ajustes de "Application Consistency".
Resolução
Actualice la acción de respaldo para incluir un usuario con derechos de administrador del sistema:

La cuenta de usuario especificada debe tener derechos de sysadmin. Esto se puede confirmar en SQL Server Management Studio (SSMS) en la VM de SQL:

Mais informações
MSVMAPPAGENT Los registros se pueden encontrar en la VM de SQL en C:\Program Files\DPSAPPS\MSVMAPPAGENT\logs
Produtos afetados
NetWorkerProdutos
NetWorker Family, NetWorker SeriesPropriedades do artigo
Número do artigo: 000221097
Tipo de artigo: Solution
Último modificado: 30 dez. 2025
Versão: 4
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.