Windows Server: O relógio do sistema não é sincronizado devido a uma grande diferença de tempo

Resumo: Este artigo descreve um problema no qual o serviço de tempo do Windows não sincroniza o relógio do sistema com uma fonte de tempo. Isso pode acontecer se a diferença de hora entre o relógio local e o relógio de origem for muito grande. ...

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

  • A hora em um sistema Windows está incorreta.
  • O serviço de Tempo do Windows está configurado para sincronizar com uma fonte de tempo, mas não consegue fazer isso.
  • O comando w32tm /resync O comando retorna "O computador não ressincronizou porque a mudança de horário necessária era muito grande".
    Erro indicando que a mudança de horário necessária é muito grande
  • O log de eventos do sistema contém o erro Time-Service 34, que também se refere a uma grande diferença de tempo.
    Erro de serviço de tempo 34, indicando uma grande diferença de tempo

Causa

Se a diferença de hora entre o relógio local e sua origem exceder um determinado limite, o relógio local não sincronizará imediatamente.

Resolução

Muitas vezes, nenhuma ação é necessária, e o serviço de Tempo do Windows eventualmente sincroniza o relógio do sistema local com sua origem. Se a sincronização imediata for necessária, um dos dois valores do Registro poderá ser modificado para que isso aconteça.

Local do registro: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config

  • MaxPosPhaseCorrection: Esse valor especifica a maior correção de tempo positiva (em segundos) que o sistema fará.
  • MaxNegPhaseCorrection: Esse valor especifica a maior correção de tempo negativa (em segundos) que o sistema fará.

O local do registro dos valores MaxPosPhaseCorrection e MaxNegPhaseCorrection

Se o bloqueio do sistema precisar avançar para atingir a hora correta, defina o valor de MaxPosPhaseCorrection. Se for necessário retroceder, defina o valor de MaxNegPhaseCorrection. A diferença de hora entre o relógio local e sua origem é dada na descrição do erro Time-Service 34, conforme mostrado acima. Defina um desses valores de registro para ser maior do que o mostrado no erro ou defina-o como FFFFFFFF (hexadecimal) para especificar sem limite.

Reinicie o serviço de Hora do Windows para que a alteração entre em vigor. O relógio deve ser sincronizado logo após o serviço ser reiniciado. A alteração do registro pode então ser revertida.

Mais informações

Grandes diferenças de horário (na ordem de dias ou semanas, por exemplo) são incomuns se o serviço de Tempo do Windows estiver configurado corretamente. No entanto, eles podem ocorrer como resultado da aplicação de um snapshot ou checkpoint de uma máquina virtual.

Tenha cuidado ao induzir grandes alterações de tempo em um domínio do Active Directory (AD), pois isso pode interferir na autenticação Kerberos. Uma alteração de horário extrema em um controlador de domínio do AD pode fazer com que o tempo desde sua última replicação bem-sucedida exceda a vida útil da floresta.

Produtos afetados

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022

Produtos

PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440 , PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Propriedades do artigo
Número do artigo: 000226718
Tipo de artigo: Solution
Último modificado: 07 jan. 2025
Versão:  2
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.