Avamar og Embedded Service Enabler (ESE): Kernefejlhændelser

Resumo: Denne artikel beskriver, hvordan du stopper startertjenesten Embedded Service Enabler (ESE) i at logge til rsyslog for at stoppe forkert generering af kernefejlhændelser.

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

Avamar-serveren er på version 19.10 eller nyere, som understøtter Dell Connectivity with Embedded Service Enabler (ESE).

Kernefejlhændelser, der rapporteres af Avamar, kan se ud som følgende output.

Event Code = 1
Event Date/Time = 10/28-06:42:15.00000
Event Type = ERROR
Event Severity = PROCESS
Event Summary = kernel error: Oct 28 06:42:08 avamarlab ese_launcher[24557]: 24557 2024-10-28 06:42:08,250 App Poller ERROR   DellESE.ese.remote_support.app_polling.app_polling_interface_connection LN: 67 Interface details not found
Software Source = DPN:Unknown
Hardware Source = avamarlab Administrator Server = avamarlab Administrator Server version = 19.10.0-166_HF338862 Avamar Server = avamarlab Avamar Server systemid = 1589815007@00:50:56:8E:1E:BD Avamar Server productId = null Avamar Server version = 19.10.0-166 Backup & Recovery Manager Url = avamarlab Data Domain System = ddlab Data Domain System OS version = 7.7.5.11-1046187 Data Domain System serial number = AUDVSDBC4XDDRW Data Domain System = ddlab Data Domain System OS version = 7.7.5.1-1040473 Data Domain System serial number = AUDVSDBC4XDDRW Event Data = Entry key = date Entry value = 2024/10/28 Entry key = code Entry value = 0001 Entry key = time Entry value = 05:42:15.09665 UTC Entry key = thread Entry value = log-messages:109 Entry key = type Entry value = ERROR Entry key = message
Entry value = kernel error: Oct 28 06:42:08 avamarlab ese_launcher[24557]: 24557 2024-10-28 06:42:08,250 App Poller ERROR   DellESE.ese.remote_support.app_polling.app_polling_interface_connection LN: 67 Interface details not found
Entry key = nodeid
Entry value = 0.0
Entry key = requestor
Entry value = <requestor
 domain="/"
 product="MCS"
 role="Administrator"
 user="root" />

 

Causa

Embedded Service Enabler (ESE) er en produktuafhængig python-software, der kan konfigureres på Avamar til at sende telemetrioplysninger til Dell Technologies.

ESE kan sende telemetridata med direkte forbindelser fra Avamar-serveren til Dell-backend eller ved hjælp af Secure Connect Gateway (SCG).

Avamar konfigurerer ESE i systemd med tjenesten "ese_launcher", der som standard logger på følgende fil.

/var/log/messages

Den konfiguration, der sender logfilerne dertil, er rsyslog.

/etc/rsyslog.conf

På grund af følgende linje i rsyslog-konfigurationen logger den stort set alt undtagen mail og nyheder i systemd til meddelelsesfilplaceringen.

*.*;mail.none;news.none                 -/var/log/messages

Når der er en fejl i ESE-tjenesten, logges den på meddelelsesplaceringen, og konfigurationen af serverlogscanneren markerer den som en kernefejl.

Det er ikke korrekt at markere ESE-fejlene som kernefejl, da ESE ikke er en del af kernen og har sin egen logføring på følgende placering.

/opt/ese/var/log/*

 

Resolução

Da ESE-tjenesten har sin egen logføringsimplementering, bør fejlfinding af ESE-tjenesten ske fra ESE-logmappen, ikke meddelelsesfilerne.

Stop logføringen af ESE-tjenesten i meddelelsesfilen og rapportering af falsk kernefejl for tjenesten ved at ændre rsyslog-konfigurationen.

Tag en sikkerhedskopi af rsyslog-konfigurationsfilen.

cp -p /etc/rsyslog.conf /etc/x-rsyslog.conf

Kør følgende kommando som root-bruger:

grep -q "if \$programname == 'ese_launcher' then stop" /etc/rsyslog.conf || sed -i '1i if \$programname == '\''ese_launcher'\'' then stop' /etc/rsyslog.conf

Genstart rsyslog-tjenesten.

systemctl restart rsyslog

 

Produtos afetados

Avamar Server
Propriedades do artigo
Número do artigo: 000246098
Tipo de artigo: Solution
Último modificado: 13 jan. 2026
Versão:  3
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.