NetWorker:Exchange 備份失敗並顯示錯誤:nsrnmmsv Exchange2010 Shell 介面未初始化
摘要: Exchange 備份失敗並顯示錯誤:nsrnmmsv Exchange2010 Shell 介面未初始化。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
適用於 Microsoft 的 NetWorker 模組 (NMM) Exchange 備份或「nsrnmmsv -P」命令失敗,並出現下列錯誤:
Exchange2010 Shell interface is not initialised.
例如:
C:\Users\Administrator>nsrnmmsv -P 17092:nsrnmmsv: Version information for C:\Program Files\EMC NetWorker\nsr\bin\nsrnmmsv.exe: Original file name: nsrnmmsv.exe Version: 9.1.1 (ntx64) Comments: Supporting Microsoft Volume Shadow Copy Service Changing backup name EX01N3 to primary name ex01n3.group.com for multi-NIC configured client. 136553:nsrnmmsv: NMM .. Exchange2010 Shell interface is unavailable. This may indicate that the EMC powershell library was not properly registered. 111867:nsrnmmsv:Exchange2010 Shell interface is not initialised. 145370:nsrnmmsv: Initialization error -- Exchange shell failed to initialize. Required for Exchange. 117296:nsrnmmsv: Failed to list supported save sets. 102332:nsrnmmsv: Exiting with success.
原因
可使用 Exchange2010 Shell interface is not initialised 錯誤訊息是由於下列其中一項:
- NetWorker lib 無法初始化 Exchange PowerShell。
- 調用 lib 的用戶沒有運行 shell 的正確許可權。
- 在極少數情況下,Exchange PowerShell 在無法執行的 IIS 組態下損壞。
解析度
檢查登錄檔項目是否存在。在這種情況下,請將該條目與其中一個工作 Exchange 節點進行比較:
reg query HKEY_LOCAL_MACHINE\software\legato\networker\vssclient
如果不存在,請繼續執行下列步驟:
-
在以下位置建立以下註冊表項:
HKEY_LOCAL_MACHINE\software\legato\networker\vssclient*** N.B. Put the appropriate username and domain name. Exchange Username REG_SZ admin Exchange Domain REG_SZ fall.localdomain Exchange Password REG_BINARY
範例:
Username= 這是使用者名稱。例如:backup.manager
Domain= 範例:BWK.com請注意Exchange Domain是 Exchange 伺服器的域級別,而不是用戶帳戶。如果域帳戶位於不同的級別(即child.fall.localdomain),編輯域以匹配使用者域,或在與 Exchange Server 完全相同的域級別中創建新使用者。 -
執行 NMM Exchange 管理員組態工具 ,然後選擇 更新管理員密碼。如果成功,應會更新 Exchange 密碼登錄機碼。
-
執行下列命令以測試 Exchange 節點的連線能力:
nsrnmmsv -P
受影響的產品
NetWorker Module for Microsoft產品
NetWorker, NetWorker Module for Microsoft文章屬性
文章編號: 000061769
文章類型: Solution
上次修改時間: 18 4月 2026
版本: 10
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。