OS10 Enterprise Edition User Guide Release 10.4.1.0

PDF

Configure virtual IP address

Configure the virtual IP address — the primary IP address and the virtual IP addresses must be on the same subnet.

  1. Configure a VRRP group in INTERFACE mode (1 to 255).
    vrrp-group 
                                           vrrp-id
                                        
  2. Configure virtual IP addresses for this VRRP ID in INTERFACE-VRRP mode (up to 10 IP addresses).
    virtual-address 
                                           ip-address1 [
                                           ...ip-address12]
                                        

Configure virtual IP address

OS10(config)# interface ethernet 1/1/1
                                 OS10(conf-if-eth1/1/1)# no switchport
                                 OS10(conf-if-eth1/1/1)# ip address 10.1.1.1/24
                                 OS10(conf-if-eth1/1/1)# vrrp-group 10
                                 OS10(conf-eth1/1/1-vrid-10)# virtual-address 10.1.1.8
                              

Verify virtual IP address

OS10# show running-configuration
                                 ! Version 10.1.9999P.2281
                                 ! Last configuration change at Jul  26 12:01:58 2016
                                 !
                                 aaa authentication system:local
                                 !
                                 interface ethernet1/1/1
                                 ip address 10.1.1.1/24
                                 no switchport
                                 no shutdown
                                 !
                                 vrrp-group 10
                                 virtual-address 10.1.1.8
                                 !
                                 interface ethernet1/1/2
                                 switchport access vlan 1
                                 no shutdown
                                 !
                                 interface ethernet1/1/3
                                 switchport access vlan 1
                                 no shutdown
                                 !
                                 interface ethernet1/1/4
                                 switchport access vlan 1
                                 --more--
                              

View VRRP information

When the VRRP process completes initialization, the State field contains either master or backup.

OS10# show vrrp brief
                                 Interface      Group   Priority  Preemption  State Master-addr  Virtual addr(s)
                                 ----------------------------------------------------------------------------
                                 ethernet1/1/1  IPv4 10 100       true       master 10.1.1.8    10.1.1.8
                              

View VRRP group 1

OS10# show vrrp 1
                                 Interface : ethernet1/1/1    IPv4 VRID : 1
                                 Primary IP Address : 10.1.1.1    State : master-state
                                 Virtual MAC Address : 00:00:5e:00:01:01
                                 Version : version-3    Priority : 100
                                 Preempt :     Hold-time :
                                 Authentication : no-authentication
                                 Virtual IP address :
                                 10.1.1.1
                                 master-transitions : 1    advertise-rcvd : 0
                                 advertise-interval-errors : 0    ip-ttl-errors : 0
                                 priority-zero-pkts-rcvd : 0    priority-zero-pkts-sent : 0
                                 invalid-type-pkts-rcvd : 0    address-list-errors : 0
                                 pkt-length-errors : 0
                              

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\