OS10 Enterprise Edition User Guide Release 10.4.0E(R3)

PDF

Candidate configuration

When you enter OS10 configuration commands in the transaction-based configuration mode, changes do not take effect immediately and are stored in the candidate configuration. The configuration changes become active on the network device only after you commit the changes with the commit command. Changes in the candidate configuration are validated and applied to the running configuration.

The candidate configuration allows you to avoid introducing errors during an OS10 configuration session. You can make changes and then check them before committing them to the active, running configuration on the network device.

Use the show diff command to check differences between the running configuration and the candidate configuration. After comparing the two, you can decide if you would like to commit the changes to the running configuration. Use the discard command to delete uncommitted changes.

  • Enter show ? from EXEC mode to view a list of commands to monitor a device.
    OS10# show ?
                                        aaa                Current candidate aaa configuration
                                        access-list        Current candidate access-list configuration
                                        as-path            Current candidate as-path configuration
                                        bgp                Current candidate bgp configuration
                                        class-map          Current candidate class-map configuration
                                        community-list     Current candidate community-list configuration
                                        compressed         Current candidate configuration in compressed format
                                        control-plane      Current candidate control-plane configuration
                                        dot1x              Current candidate dot1x configuration
                                        extcommunity-list  Current candidate extcommunity-list configuration
                                        interface          Current candidate interface configuration
                                        lacp               Current candidate lacp configuration
                                        lldp               Current candidate lldp configuration
                                        logging            Current candidate logging configuration
                                        monitor            Current candidate monitor session configuration
                                        ospf               Current candidate ospf configuration
                                        ospfv3             Current candidate ospfv3 configuration
                                        policy-map         Current candidate policy-map configuration
                                        prefix-list        Current candidate prefix-list configuration
                                        qos-map            Current candidate qos-map configuration
                                        radius-server      Current candidate radius-server configuration
                                        route-map          Current candidate route-map configuration
                                        sflow              Current candidate sFlow configuration
                                        snmp               Current candidate snmp configuration
                                        spanning-tree      Current candidate spanning-tree configuration
                                        support-assist     Current candidate support-assist configuration
                                        system-qos         Current candidate system-qos configuration
                                        trust-map          Current candidate trust-map configuration
                                        users              Current candidate users configuration
                                        vlt                Current candidate vlt domain configuration
                                     
View compressed candidate configuration
OS10# show candidate-configuration compressed
                                 interface breakout 1/1/1 map 40g-1x
                                 interface breakout 1/1/2 map 40g-1x
                                 interface breakout 1/1/3 map 40g-1x
                                 interface breakout 1/1/4 map 40g-1x
                                 interface breakout 1/1/5 map 40g-1x
                                 interface breakout 1/1/6 map 40g-1x
                                 interface breakout 1/1/7 map 40g-1x
                                 interface breakout 1/1/8 map 40g-1x
                                 interface breakout 1/1/9 map 40g-1x
                                 interface breakout 1/1/10 map 40g-1x
                                 interface breakout 1/1/11 map 40g-1x
                                 interface breakout 1/1/12 map 40g-1x
                                 interface breakout 1/1/13 map 40g-1x
                                 interface breakout 1/1/14 map 40g-1x
                                 interface breakout 1/1/15 map 40g-1x
                                 interface breakout 1/1/16 map 40g-1x
                                 interface breakout 1/1/17 map 40g-1x
                                 interface breakout 1/1/18 map 40g-1x
                                 interface breakout 1/1/19 map 40g-1x
                                 interface breakout 1/1/20 map 40g-1x
                                 interface breakout 1/1/21 map 40g-1x
                                 interface breakout 1/1/22 map 40g-1x
                                 interface breakout 1/1/23 map 40g-1x
                                 interface breakout 1/1/24 map 40g-1x
                                 interface breakout 1/1/25 map 40g-1x
                                 interface breakout 1/1/26 map 40g-1x
                                 interface breakout 1/1/27 map 40g-1x
                                 interface breakout 1/1/28 map 40g-1x
                                 interface breakout 1/1/29 map 40g-1x
                                 interface breakout 1/1/30 map 40g-1x
                                 interface breakout 1/1/31 map 40g-1x
                                 interface breakout 1/1/32 map 40g-1x
                                 ipv6 forwarding enable
                                 username admin password $6$q9QBeYjZ$jfxzVqGhkxX3smxJSH9DDz7/3OJc6m5wjF8nnLD7/VKx8SloIhp4NoGZs0I/UNwh8WVuxwfd9q4pWIgNs5BKH.
                                 role sysadmin
                                 aaa authentication local
                                 snmp-server contact http://www.dell.com/support
                                 !
                                 interface range ethernet 1/1/1-1/1/32
                                 switchport access vlan 1
                                 no shutdown
                                 !
                                 interface vlan 1
                                 no shutdown
                                 !
                                 interface mgmt1/1/1
                                 ip address dhcp
                                 no shutdown
                                 ipv6 enable
                                 ipv6 address autoconfig
                                 !
                                 support-assist
                                 !
                                 policy-map type application policy-iscsi
                                 !
                                 class-map type application class-iscsi
                                 !
                                 class-map type qos class-trust
                              
View compressed running configuration
OS10# show running-configuration compressed
                                 interface breakout 1/1/1 map 40g-1x
                                 interface breakout 1/1/2 map 40g-1x
                                 interface breakout 1/1/3 map 40g-1x
                                 interface breakout 1/1/4 map 40g-1x
                                 interface breakout 1/1/5 map 40g-1x
                                 interface breakout 1/1/6 map 40g-1x
                                 interface breakout 1/1/7 map 40g-1x
                                 interface breakout 1/1/8 map 40g-1x
                                 interface breakout 1/1/9 map 40g-1x
                                 interface breakout 1/1/10 map 40g-1x
                                 interface breakout 1/1/11 map 40g-1x
                                 interface breakout 1/1/12 map 40g-1x
                                 interface breakout 1/1/13 map 40g-1x
                                 interface breakout 1/1/14 map 40g-1x
                                 interface breakout 1/1/15 map 40g-1x
                                 interface breakout 1/1/16 map 40g-1x
                                 interface breakout 1/1/17 map 40g-1x
                                 interface breakout 1/1/18 map 40g-1x
                                 interface breakout 1/1/19 map 40g-1x
                                 interface breakout 1/1/20 map 40g-1x
                                 interface breakout 1/1/21 map 40g-1x
                                 interface breakout 1/1/22 map 40g-1x
                                 interface breakout 1/1/23 map 40g-1x
                                 interface breakout 1/1/24 map 40g-1x
                                 interface breakout 1/1/25 map 40g-1x
                                 interface breakout 1/1/26 map 40g-1x
                                 interface breakout 1/1/27 map 40g-1x
                                 interface breakout 1/1/28 map 40g-1x
                                 interface breakout 1/1/29 map 40g-1x
                                 interface breakout 1/1/30 map 40g-1x
                                 interface breakout 1/1/31 map 40g-1x
                                 interface breakout 1/1/32 map 40g-1x
                                 ipv6 forwarding enable
                                 username admin password $6$q9QBeYjZ$jfxzVqGhkxX3smxJSH9DDz7/3OJc6m5wjF8nnLD7/VKx8SloIhp4NoGZs0I/UNwh8WVuxwfd9q4pWIgNs5BKH.
                                 role sysadmin
                                 aaa authentication local
                                 snmp-server contact http://www.dell.com/support
                                 !
                                 interface range ethernet 1/1/1-1/1/32
                                 switchport access vlan 1
                                 no shutdown
                                 !
                                 interface vlan 1
                                 no shutdown
                                 !
                                 interface mgmt1/1/1
                                 ip address dhcp
                                 no shutdown
                                 ipv6 enable
                                 ipv6 address autoconfig
                                 !
                                 support-assist
                                 !
                                 policy-map type application policy-iscsi
                                 !
                                 class-map type application class-iscsi
                                 !
                                 class-map type qos class-trust
                                 
                              
Show difference between candidate and running configurations
OS10# show diff candidate-configuration running-configuration
                                 OS10#
                              
  • NOTE: If the OS10# prompt does not return output, the candidate-configuration and running-configuration files match.

Prevent configuration changes

You can prevent configuration changes on sessions other than the current CLI session using the lock command. Use the lock and unlock commands in EXEC mode to respectively prevent and allow configuration changes on other sessions. When you enter the lock command on a CLI session, users cannot make configuration changes across any other active CLI sessions. When you close the CLI session on which you entered the lock command, configuration changes are automatically allowed on all other sessions.

Lock configuration changes

OS10# lock 

Unlock configuration changes

OS10# unlock 

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\