OS10 Enterprise Edition User Guide Release 10.4.0E(R3)

PDF

Configure interface ranges

Bulk interface configuration allows you apply the same configuration to multiple interfaces - either physical or logical, or to display their current configuration. You can also create multiple logical interfaces in bulk. An interface range is a set of interfaces to which you can apply the same command.

You can use interface ranges for:

  • Ethernet physical interfaces
  • Port channels
  • VLAN interfaces

Bulk configuration excludes any non-existing interfaces in an interface range from the configuration. You can configure a default VLAN only if the interface range being configured consists of only VLAN ports.

The interface range command allows you to create an interface range allowing other commands to be applied to that range of interfaces.

Configure range of Ethernet addresses and enable them
OS10(config)# interface range ethernet 1/1/1-1/1/5
                                 OS10(conf-range-eth1/1/1-1/1/5)# no shutdown
                                 
                              
View the configuration
OS10(conf-range-eth1/1/1-1/1/5)# show configuration
                                 !
                                 interface ethernet1/1/1
                                 no shutdown
                                 switchport access vlan 1
                                 !
                                 interface ethernet1/1/2
                                 no shutdown
                                 switchport access vlan 1
                                 !
                                 interface ethernet1/1/3
                                 no shutdown
                                 switchport access vlan 1
                                 !
                                 interface ethernet1/1/4
                                 no shutdown
                                 switchport access vlan 1
                                 !
                                 interface ethernet1/1/5
                                 no shutdown
                                 switchport access vlan 1
                                 
                              
Configure range of VLANs
OS10(config)# interface range vlan 1-100
                                 OS10(conf-range-vl-1-100)#
                                 
                              
Configure range of port channels
OS10(config)# interface range port-channel 1-25
                                 OS10(conf-range-po-1-25)#
                                 
                              

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\