OS10 Enterprise Edition User Guide Release 10.4.0E(R3)

PDF

Enable BGP

BGP is disabled by default. The system supports one AS number — you must assign an AS number to your device. To establish BGP sessions and route traffic, configure at least one BGP neighbor or peer. In BGP, routers with an established TCP connection are called neighbors or peers. After a connection establishes, the neighbors exchange full BGP routing tables with incremental updates afterward. Neighbors also exchange the KEEPALIVE messages to maintain the connection.

You can classify BGP neighbor routers or peers as internal or external. Connect EBGP peers directly, unless you enable EBGP multihop — IBGP peers do not need direct connection. The IP address of an EBGP neighbor is usually the IP address of the interface directly connected to the router. The BGP process first determines if all internal BGP peers are reachable, then it determines which peers outside the AS are reachable.

  1. Assign an AS number, and enter ROUTER-BGP mode from CONFIGURATION mode (1 to 65535 for 2-byte, 1 to 4294967295 for 4-byte). Only one AS number is supported per system. If you enter a 4-byte AS number, 4-byte AS support is enabled automatically.
    router bgp 
                                           as-number
                                        
  2. Enter a neighbor in ROUTER-BGP mode.
    neighbor 
                                           ip-address
                                        
  3. Add a remote AS in ROUTER-NEIGHBOR mode, from 1 to 65535 for 2-byte or 1 to 4294967295 for 4-byte.
    remote-as 
                                           as-number
                                        
  4. Enable the BGP neighbor in ROUTER-NEIGHBOR mode.
    no shutdown

To reset the configuration when you change the configuration of a BGP neighbor, use the clear ip bgp * command. To view the BGP status, use the show ip bgp summary command.

View BGP summary with 2-byte AS number

OS10# show ip bgp summary
                                 
                                 BGP router identifier 202.236.164.86 local AS number 64901
                                 Neighbor AS MsgRcvd MsgSent Up/Down State/Pfx
                                 120.10.1.1 64701 664 662 04:47:52 established 12000
                              

View BGP summary with 4-byte AS number

OS10# show ip bgp summary
                                 BGP router identifier 11.1.1.1, local AS number 4294967295
                                 BGP local RIB : Routes to be Added 0, Replaced 0, Withdrawn 0
                                 1 neighbor(s) using 8192 bytes of memory
                                 
                                 Neighbor AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/Pfx
                                 5.1.1.2 4294967295 0 0 0 0 0 00:00:00 Active
                              

For the router ID, the system selects the first configured IP address or a random number. To view the status of BGP neighbors, use the show ip bgp neighbors command. For BGP neighbor configuration information, use the show running-config bgp command.

The example shows two neighbors — one is an external BGP neighbor, and the other is an internal BGP neighbor. The first line of the output for each neighbor displays the AS number and states if the link is external or internal.

The third line of the show ip bgp neighbors output contains the BGP state. If anything other than established displays, the neighbor is not exchanging information and routes - see IPv6 commands for more information.

View BGP neighbors

OS10# show ip bgp neighbors
                                 BGP neighbor is 5.1.1.1, remote AS 1, internal link
                                 BGP version 4, remote router ID 6.1.1.1
                                 BGP state established, in this state for 00:03:11
                                 Last read 01:08:40 seconds, hold time is 180, keepalive interval is 60 seconds
                                 Received 11 messages
                                 3 opens, 1 notifications, 3 updates
                                 4 keepalives, 0 route refresh requests
                                 Sent 14 messages
                                 3 opens, 1 notifications, 0 updates
                                 10 keepalives, 0 route refresh requests
                                 
                                 Minimum time between advertisement runs is seconds
                                 
                                 Capabilities received from neighbor for IPv4 Unicast:
                                 MULTIPROTO_EXT(1)ROUTE_REFRESH(2)CISCO_ROUTE_REFRESH(128)
                                 Capabilities advertised to neighbor for IPv4 Unicast:
                                 MULTIPROTO_EXT(1)ROUTE_REFRESH(2)CISCO_ROUTE_REFRESH(128)
                                 
                                 Prefixes accepted 3, Prefixes advertised 0
                                 
                                 Connections established 3; dropped 2
                                 Closed by neighbor sent 00:03:26 ago
                                 
                                 Local host: 5.1.1.2, Local port: 43115
                                 Foreign host: 5.1.1.1, Foreign port: 179
                              

View BGP running configuration

OS10# show running-configuration
                                 
                                 router bgp 65123
                                 router-id 192.168.10.2
                                 !
                                 address-family ipv4 unicast
                                 !
                                 neighbor 10.10.21.1
                                 remote-as 65123
                                 no shutdown
                                 !
                                 neighbor 10.10.32.3
                                 remote-as 65123
                                 no shutdown
                                 !
                                 neighbor 100.10.92.9
                                 remote-as 65192
                                 no shutdown
                                 !
                                 neighbor 192.168.10.1
                                 remote-as 65123
                                 update-source Loopback loopback0
                                 no shutdown
                                 !
                                 neighbor 192.168.12.2
                                 remote-as 65123
                                 update-source Loopback loopback0
                                 no shutdown
                                 !
                              

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\