OS10 Enterprise Edition User Guide Release 10.4.0E(R3)

PDF

Enable OSPFv2

OSPFv2 is disabled by default. Configure at least one interface as either physical or LOOPBACK and assign an IP address to the interface. You can assign any area besides area 0 a number ID. The OSPFv2 process starts automatically when you configure it globally and you can enable it for one or more interfaces.

  1. Enable OSPF globally and configure an OSPF instance in CONFIGURATION mode.
    router ospf 
                                           instance-number
                                        
  2. Enter the interface information to configure the interface for OSPF in INTERFACE mode.
    interface ethernet 
                                           node/slot/port[:subport]
                                        
  3. Enable the interface in INTERFACE mode.
    no shutdown
  4. Disable the default switchport configuration and remove it from an interface or a LAG port in INTERFACE mode.
    no switchport
  5. Assign an IP address to the interface in INTERFACE mode.
    ip address 
                                           ip-address/mask
                                        
  6. Enable OSPFv2 on an interface in INTERFACE mode.
    ip ospf 
                                           process-id area 
                                           area-id
                                        
    • process-id —Enter the OSPFv2 process ID for a specific OSPF process from 1 to 65535.
    • area-id —Enter the OSPFv2 area ID as an IP address (A.B.C.D) or number from 1 to 65535.

Enable OSPFv2 configuration

OS10(config)# router ospf 100
                                 OS10(conf-router-ospf-100)# exit
                                 OS10(config)#  interface ethernet 1/1/1
                                 OS10(conf-if-eth1/1/1)# no shutdown
                                 OS10(conf-if-eth1/1/1)# no switchport
                                 OS10(conf-if-eth1/1/1)# ip address 11.1.1.1/24
                                 OS10(conf-if-eth1/1/1)# ip ospf 100 area 0.0.0.0
                              

View OSPFv2 configuration

OS10# show running-configuration ospf
                                 !
                                 interface ethernet1/1/1
                                 ip ospf 100 area 0.0.0.0
                                 !
                                 router ospf 100
                                 ...
                              

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\