OS10 Enterprise Edition User Guide Release 10.4.0E(R3)

PDF

Fast external fallover

Fast external fallover terminates EBGP sessions of any directly adjacent peer if the link used to reach the peer goes down. BGP does not wait for the hold-down timer to expire.

Fast external fallover is enabled by default. To disable or re-enable it, use the [no] fast-external-fallover command. For the fast-external-fallover command to take effect on an established BGP session, you must reset the session using the clear ip bgp {* | peer-ipv4-address | peer-ipv6-address} command.

View fast external fallover configuration

OS10(config)# do show running-configuration bgp
                                 !
                                 router bgp 300
                                 !
                                 neighbor 3.1.1.1
                                 remote-as 100
                                 no shutdown
                                 !
                                 neighbor 3::1
                                 remote-as 100
                                 no shutdown
                                 !
                                 address-family ipv6 unicast
                                 activate
                                 OS10(config)# interface ethernet 1/1/1
                                 OS10(conf-if-eth1/1/1)# show configuration
                                 !
                                 interface ethernet1/1/1
                                 ip address 3.1.1.3/24
                                 no switchport
                                 no shutdown
                                 ipv6 address 3::3/64
                                 OS10(conf-if-eth1/1/1)# shutdown
                                 OS10(conf-if-eth1/1/1)# do show ip bgp summary
                                 BGP router identifier 11.11.11.11 local AS number 300
                                 Neighbor                                      AS          MsgRcvd     MsgSent     Up/Down           State/Pfx
                                 3.1.1.1                                       100         6           6           00:00:15          Active
                                 3::1                                          100         8           11          00:00:15          Active
                                 OS10(conf-if-eth1/1/1)#
                              

View fast external fallover unconfiguration

OS10(config-router-bgp-300)# do show running-configuration bgp
                                 !
                                 router bgp 300
                                 no fast-external-fallover
                                 !
                                 neighbor 3.1.1.1
                                 remote-as 100
                                 no shutdown
                                 !
                                 neighbor 3::1
                                 remote-as 100
                                 no shutdown
                                 !
                                 address-family ipv6 unicast
                                 activate
                                 OS10(config-router-bgp-300)#
                                 OS10(conf-if-eth1/1/1)# do clear ip bgp *
                                 OS10# show ip bgp summary
                                 BGP router identifier 11.11.11.11 local AS number 300
                                 Neighbor  AS          MsgRcvd     MsgSent     Up/Down     State/Pfx
                                 -----------------------------------------------------------------
                                 3.1.1.1   100         7           4           00:00:08    3
                                 3::1      100         9           5           00:00:08    4
                                 OS10#
                                 OS10(config)# interface ethernet 1/1/1
                                 OS10(conf-if-eth1/1/1)# shutdown
                                 OS10(conf-if-eth1/1/1)# do show ip bgp summary
                                 BGP router identifier 11.11.11.11 local AS number 300
                                 Neighbor  AS          MsgRcvd     MsgSent     Up/Down     State/Pfx
                                 -----------------------------------------------------------------
                                 3.1.1.1   100         7           4           00:00:29    3
                                 3::1      100         9           5           00:00:29    4
                                 OS10(conf-if-eth1/1/1)#
                                 OS10(config-router-bgp-neighbor-af)# Apr 27 01:39:03 OS10 dn_sm[2065]: Node.1-Unit.1:PRI:alert [os10:event],
                                 %Dell EMC (OS10) %BGP_NBR_BKWD_STATE_CHG: Backward state change occurred Hold Time expired for Nbr:3.1.1.3 VRF:default
                                 Apr 27 01:39:03 OS10 dn_sm[2065]: Node.1-Unit.1:PRI:alert [os10:event], %Dell EMC (OS10) %BGP_NBR_BKWD_STATE_CHG: Backward
                                 state change occurred Hold Time expired for Nbr:3::3 VRF:default
                              

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\