OS10 Enterprise Edition User Guide Release 10.4.0E(R3)

PDF

L2 mode configuration

All physical, Ethernet and port-channel interfaces use a single MAC address and, by default, operate in L2 mode. From L2 mode, you can configure switching and L2 protocols, such as VLANs and spanning-tree protocol (STP) on an interface.

You can enable L2 switching on a port interface in access or trunk mode. By default, an interface is configured in access mode. Access mode allows L2 switching of untagged traffic on a single VLAN (VLAN 1 is the default). Trunk mode enables L2 switching of untagged traffic on the access VLAN, and tagged traffic on multiple (two or more) VLANs.

A trunk interface carries VLAN traffic that is tagged using 802.1q encapsulation. If an access interface receives a packet with an 802.1q tag in the header that is different from the access VLAN ID, it drops the packet.

By default, a trunk interface carries only untagged traffic on the access VLAN — you must manually configure other VLANs for tagged traffic.

  1. Select one of the two available options:
    • Configure L2 trunking in INTERFACE mode and the tagged VLAN traffic that the port can transmit. By default, a trunk port is not added to any tagged VLAN. You must create a VLAN before you can assign the interface to it.
      switchport mode trunk
                                                   switchport trunk allowed vlan 
                                                   vlan-id-list
                                                
    • Reconfigure the access VLAN assigned to a L2 access or trunk port in INTERFACE mode.
      switchport access vlan 
                                                   vlan-id 
                                                
  2. Enable the interface for L2 traffic transmission in INTERFACE mode.
    no shutdown
L2 interface configuration
OS10(config)# interface ethernet 1/1/7
                                    OS10(conf-if-eth1/1/7)# switchport mode trunk
                                    OS10(conf-if-eth1/1/7)# switchport trunk allowed vlan 5,10
                                    OS10(conf-if-eth1/1/7)# no shutdown
                                 

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\