OS10 Enterprise Edition User Guide Release 10.4.0E(R3)

PDF

Migrate VMs across data centers

OS10 does not support proxy gateway. Instead of proxy gateway, you can use VRRP in VLANs to migrate virtual machines across data centers.

You must assign same VRRP group IDs to the VLANs in L3 mode, with VRRP in active-active mode.

The following illustration shows a sample configuration with two data centers:

Migration of VMs across data centers
  • Server racks, Rack 1 and Rack 2, are part of data centers DC1 and DC2, respectively.
  • Rack 1 is connected to devices A1 and B1 in a Layer 2 network segment.
  • Rack 2 is connected to devices A2 and B2 in a Layer 2 network segment.
  • A VLT link aggregation group (LAG) is present between A1 and B1 as well as A2 and B2.
  • A1 and B1 are connected to core routers, C1 and D1 with VLT routing enabled.
  • A2 and B2 are connected to core routers, C2 and D2, with VLT routing enabled.
  • The core routers C1 and D1 in the local VLT domain are connected to the core routers C2 and D2 in the remote VLT Domain using VLT links.
  • The core routers C1 and D1 in local VLT Domain along with C2 and D2 in the remote VLT Domain are part of a Layer 3 cloud.
  • The core routers C1, D1, C2, D2 are in a VRRP group with the same vrrp-group ID.

When a virtual machine running in Server Rack 1 migrates to Server Rack 2, L3 packets for that VM are routed through the default gateway.

The following examples show sample configurations of the core routers.

Sample configuration of C1:

  • Configure peer routing:
    C1(config)# vlt-domain 10
                                        C1(conf-vlt-10)# discovery-interface ethernet1/1/1
                                        C1(conf-vlt-10)# discovery-interface ethernet1/1/2
                                        C1(conf-vlt-10)# peer-routing
                                        C1(conf-vlt-10)# exit
                                     
  • Configure VRRP on L2 links between core routers:
    C1(config)# interface vlan 100
                                        C1(conf-if-vl-100)# ip address 10.10.100.1/30
                                        C1(conf-if-vl-100)# vrrp-group 10
                                        
                                     
  • Configure VLT port channel for VLAN 100:
    C1(config)# interface port-channel 10
                                        C1(conf-if-po-10)# vlt-port-channel 10
                                        C1(conf-if-po-10)# switchport mode trunk
                                        C1(conf-if-po-10)# switchport trunk allowed vlan 100 
                                        C1(conf-if-po-10)# exit
                                     
  • Add members to port channel 10:
    C1(config)# interface ethernet 1/1/3
                                        C1(conf-if-eth1/1/3)# channel-group 10
                                        C1(conf-if-eth1/1/3)# exit
                                        C1(config)# interface ethernet 1/1/4
                                        C1(conf-if-eth1/1/4)# channel-group 10
                                        C1(conf-if-eth1/1/4)# exit
                                        
                                     
  • Configure OSPF on L3 side of core router:
    C1(config)# router ospf 100
                                        C1(conf-router-ospf-100)# exit
                                        C1(config)# interface vlan 200
                                        C1(conf-if-vl-200)# ip ospf 100 area 0.0.0.0
                                     
  • Configure VLT port channel for VLAN 200:
    C1(config)# interface port-channel 20
                                        C1(conf-if-po-20)# vlt-port-channel 20
                                        C1(conf-if-po-20)# switchport mode trunk
                                        C1(conf-if-po-20)# switchport trunk allowed vlan 200 
                                        C1(conf-if-po-20)# exit
                                     
  • Add members to port channel 20:
    C1(config)# interface ethernet 1/1/5
                                        C1(conf-if-eth1/1/5)# channel-group 20
                                        C1(conf-if-eth1/1/5)# exit
                                        C1(config)# interface ethernet 1/1/6
                                        C1(conf-if-eth1/1/6)# channel-group 20
                                        C1(conf-if-eth1/1/6)# exit
                                     

Sample configuration of D1:

  • Configure peer routing:
    D1(config)# vlt-domain 10
                                        D1(conf-vlt-10)# discovery-interface ethernet1/1/1
                                        D1(conf-vlt-10)# discovery-interface ethernet1/1/2
                                        D1(conf-vlt-10)# peer-routing
                                        D1(conf-vlt-10)# exit
                                     
  • Configure VRRP on L2 links between core routers:
    D1(config)# interface vlan 100
                                        D1(conf-if-vl-100)# ip address 10.10.100.2/30
                                        D1(conf-if-vl-100)# vrrp-group 10
                                        
                                     
  • Configure VLT port channel for VLAN 100:
    D1(config)# interface port-channel 10
                                        D1(conf-if-po-10)# vlt-port-channel 10
                                        D1(conf-if-po-10)# switchport mode trunk
                                        D1(conf-if-po-10)# switchport trunk allowed vlan 100 
                                        D1(conf-if-po-10)# exit
                                     
  • Add members to port channel 10:
    D1(config)# interface ethernet 1/1/3
                                        D1(conf-if-eth1/1/3)# channel-group 10
                                        D1(conf-if-eth1/1/3)# exit
                                        D1(config)# interface ethernet 1/1/4
                                        D1(conf-if-eth1/1/4)# channel-group 10
                                        D1(conf-if-eth1/1/4)# exit
                                        
                                     
  • Configure OSPF on L3 side of core router:
    D1(config)# router ospf 100
                                        D1(conf-router-ospf-100)# exit
                                        D1(config)# interface vlan 200
                                        D1(conf-if-vl-200)# ip ospf 100 area 0.0.0.0
                                     
  • Configure VLT port channel for VLAN 200:
    D1(config)# interface port-channel 20
                                        D1(conf-if-po-20)# vlt-port-channel 20
                                        D1(conf-if-po-20)# switchport mode trunk
                                        D1(conf-if-po-20)# switchport trunk allowed vlan 200 
                                        D1(conf-if-po-20)# exit
                                     
  • Add members to port channel 20:
    D1(config)# interface ethernet 1/1/5
                                        D1(conf-if-eth1/1/5)# channel-group 20
                                        D1(conf-if-eth1/1/5)# exit
                                        D1(config)# interface ethernet 1/1/6
                                        D1(conf-if-eth1/1/6)# channel-group 20
                                        D1(conf-if-eth1/1/6)# exit
                                     

Sample configuration of C2:

  • Configure peer routing:
    C2(config)# vlt-domain 20
                                        C2(conf-vlt-20)# discovery-interface ethernet1/1/1
                                        C2(conf-vlt-20)# discovery-interface ethernet1/1/2
                                        C2(conf-vlt-20)# peer-routing
                                        C2(conf-vlt-20)# exit
                                     
  • Configure VRRP on L2 links between core routers:
    C2(config)# interface vlan 100
                                        C2(conf-if-vl-100)# ip address 10.10.100.3/30
                                        C2(conf-if-vl-100)# vrrp-group 10
                                        
                                     
  • Configure VLT port channel for VLAN 100:
    C2(config)# interface port-channel 10
                                        C2(conf-if-po-10)# vlt-port-channel 10
                                        C2(conf-if-po-10)# switchport mode trunk
                                        C2(conf-if-po-10)# switchport trunk allowed vlan 100 
                                        C2(conf-if-po-10)# exit
                                     
  • Add members to port channel 10:
    C2(config)# interface ethernet 1/1/3
                                        C2(conf-if-eth1/1/3)# channel-group 10
                                        C2(conf-if-eth1/1/3)# exit
                                        C2(config)# interface ethernet 1/1/4
                                        C2(conf-if-eth1/1/4)# channel-group 10
                                        C2(conf-if-eth1/1/4)# exit
                                        
                                     
  • Configure OSPF on L3 side of core router:
    C2(config)# router ospf 100
                                        C2(conf-router-ospf-100)# exit
                                        C2(config)# interface vlan 200
                                        C2(conf-if-vl-200)# ip ospf 100 area 0.0.0.0
                                     
  • Configure VLT port channel for VLAN 200:
    C2(config)# interface port-channel 20
                                        C2(conf-if-po-20)# vlt-port-channel 20
                                        C2(conf-if-po-20)# switchport mode trunk
                                        C2(conf-if-po-20)# switchport trunk allowed vlan 200 
                                        C2(conf-if-po-20)# exit
                                     
  • Add members to port channel 20:
    C2(config)# interface ethernet 1/1/5
                                        C2(conf-if-eth1/1/5)# channel-group 20
                                        C2(conf-if-eth1/1/5)# exit
                                        C2(config)# interface ethernet 1/1/6
                                        C2(conf-if-eth1/1/6)# channel-group 20
                                        C2(conf-if-eth1/1/6)# exit
                                     

Sample configuration of D2:

  • Configure peer routing:
    D2(config)# vlt-domain 20
                                        D2(conf-vlt-20)# discovery-interface ethernet1/1/1
                                        D2(conf-vlt-20)# discovery-interface ethernet1/1/2
                                        D2(conf-vlt-20)# peer-routing
                                        D2(conf-vlt-20)# exit
                                     
  • Configure VRRP on L2 links between core routers:
    D2(config)# interface vlan 100
                                        D2(conf-if-vl-100)# ip address 10.10.100.4/30
                                        D2(conf-if-vl-100)# vrrp-group 10
                                        
                                     
  • Configure VLT port channel for VLAN 100:
    D2(config)# interface port-channel 10
                                        D2(conf-if-po-10)# vlt-port-channel 10
                                        D2(conf-if-po-10)# switchport mode trunk
                                        D2(conf-if-po-10)# switchport trunk allowed vlan 100 
                                        D2(conf-if-po-10)# exit
                                     
  • Add members to port channel 10:
    D2(config)# interface ethernet 1/1/3
                                        D2(conf-if-eth1/1/3)# channel-group 10
                                        D2(conf-if-eth1/1/3)# exit
                                        D2(config)# interface ethernet 1/1/4
                                        D2(conf-if-eth1/1/4)# channel-group 10
                                        D2(conf-if-eth1/1/4)# exit
                                        
                                     
  • Configure OSPF on L3 side of core router:
    D2(config)# router ospf 100
                                        D2(conf-router-ospf-100)# exit
                                        D2(config)# interface vlan 200
                                        D2(conf-if-vl-200)# ip ospf 100 area 0.0.0.0
                                     
  • Configure VLT port channel for VLAN 200:
    D2(config)# interface port-channel 20
                                        D2(conf-if-po-20)# vlt-port-channel 20
                                        D2(conf-if-po-20)# switchport mode trunk
                                        D2(conf-if-po-20)# switchport trunk allowed vlan 200 
                                        D2(conf-if-po-20)# exit
                                     
  • Add members to port channel 20:
    D2(config)# interface ethernet 1/1/5
                                        D2(conf-if-eth1/1/5)# channel-group 20
                                        D2(conf-if-eth1/1/5)# exit
                                        D2(config)# interface ethernet 1/1/6
                                        D2(conf-if-eth1/1/6)# channel-group 20
                                        D2(conf-if-eth1/1/6)# exit
                                     

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\