OS10 Enterprise Edition User Guide Release 10.4.0E(R3)

PDF

OSPFv2 authentication

You can enable OSPF authentication either with clear text or with MD5.

  • Set a clear text authentication scheme on the interface in INTERFACE mode. ip ospf authentication-key key
  • Set MD5 authentication in INTERFACE mode. ip ospf message-digest-key keyid md5 key
Configure text authentication
OS10(config)# interface ethernet 1/1/1
                                    OS10(conf-if-eth1/1/1)# ip ospf authentication-key sample
                                    
                                 
View text authentication
OS10(conf-if-eth1/1/1)# show configuration 
                                    !
                                    interface ethernet1/1/1
                                    ip address 10.10.10.2/24
                                    no switchport
                                    no shutdown
                                    ip ospf 100 area 0.0.0.0
                                    ip ospf authentication-key sample
                                 
Configure MD5 authentication
OS10(config)# interface ethernet 1/1/1
                                    OS10(conf-if-eth1/1/1)# ip ospf message-digest-key 2 md5 sample12345
                                    
                                 
View MD5 authentication
OS10(conf-if-eth1/1/1)# show configuration
                                    
                                    !
                                    interface ethernet1/1/1
                                    ip address 10.10.10.2/24
                                    no switchport
                                    no shutdown
                                    ip ospf 100 area 0.0.0.0
                                    ip ospf message-digest-key 2 md5 sample12345
                                    
                                 

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\