OS10 Enterprise Edition User Guide Release 10.4.0E(R3)

PDF

Reset default configuration

You can clear all configured settings on an Ethernet or Fibre Channel interface and reset the interface to its default settings. By default:
  • An Ethernet interface is enabled ( no shutdown) and assigned to the default VLAN. An Ethernet interface has no IP address and no L2 switchport is configured ( no IP address).
  • A Fibre Channel interface is disabled ( shutdown).

Restrictions

The default interface command removes all software settings and all L3, VLAN, VXLAN, and port-channel configurations on a port interface. However, the command does not remove configurations to the interface from other software features, such as VLT. If you do not remove these configured settings, the command does not execute. For example, if an Ethernet interface is configured as a discovery interface in a VLT domain and you do not delete this setting, resetting the interface to its default configuration fails:
OS10(config)# vlt-domain 10
                                 OS10(conf-vlt-10)# discovery-interface ethernet 1/1/1
                                 OS10(conf-vlt-10)# exit
                                 OS10(config)# default interface ethernet 1/1/1
                                 Proceed to cleanup the interface config? [confirm yes/no]:y
                                 % Error: Discovery Interface mode must not be in switchport mode
                                 
                              

Configuration

  1. From CONFIGURATION mode, enter INTERFACE mode and view the currently configured settings.
    interface {ethernet | fibrechannel} 
                                        node/slot/port[:subport]
                                        show config
                                     
  2. Return to CONFIGURATION mode.
    exit
  3. Reset an interface to its default configuration in CONFIGURATION mode. Enter multiple interfaces in a comma-separated string or a port range using the default interface range command.
    default interface {ethernet | fibrechannel} 
                                        node/slot/port[:subport]
                                     
  4. Enter INTERFACE mode and verify the factory-default configuration.
    interface {ethernet | fibrechannel} 
                                        node/slot/port[:subport]
                                        show config
                                     

Reset default Ethernet configuration

OS10(conf-if-eth1/1/2)# show configuration
                              !
                              interface ethernet 1/1/2
                              no shutdown
                              no switchport
                              negotiation on
                              ip address 1.2.3.4/24
                              ip address 2.2.2.2/24 secondary
                              ip address 3.3.3.3/24 secondary
                              ipv6 address 10::1/64
                              ip access-group test in
                              lldp med network-policy add 10
                              ip ospf priority 10
                              flowcontrol transmit on
                              
                              OS10(conf-if-eth1/1/2)# exit
                              S10(config)# default interface ethernet 1/1/2
                              Proceed to cleanup the interface config? [confirm yes/no]:y
                              Sep 9 01:06:28 OS10 dn_l3_core_services[968]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %IP_ADDRESS_DEL: IP Address
                              delete is successful. IP 2.2.2.2/24 deleted successfully
                              Sep 9 01:06:28 OS10 dn_l3_core_services[968]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %IP_ADDRESS_DEL: IP Address
                              delete is successful. IP 3.3.3.3/24 deleted successfully
                              Sep 9 01:06:28 OS10 dn_l3_core_services[968]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %IP_ADDRESS_DEL: IP Address
                              delete is successful. IP 1.2.3.4/24 deleted successfully
                              Sep 9 01:06:28 OS10 dn_l3_core_services[968]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %IP_ADDRESS_DEL: IP Address
                              delete is successful. IP 10::1/64 deleted successfully
                              
                              OS10(config)# do show running-configuration interface ethernet 1/1/2
                              !
                              interface ethernet1/1/2
                              no shutdown
                              switchport access vlan 1
                           

Reset default Fibre Channel configuration

OS10# show running-configuration interface fibrechannel 1/1/1
                              !
                              interface fibrechannel1/1/1
                              no shutdown
                              description fc-port
                              
                              OS10(conf-if-fc1/1/1)# exit
                              OS10(config)# default interface fc1/1/1
                              Proceed to cleanup the interface config? [confirm yes/no]:y
                              !
                              OS10(config)# do show running-configuration interface fibrechannel 1/1/1
                              interface fibrechannel1/1/1
                              shutdown
                           

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\