OS10 Enterprise Edition User Guide Release 10.4.0E(R3)

PDF

show candidate-configuration

Displays the current candidate configuration file.

Syntax
show candidate-configuration [aaa | access-list | as-path | bgp | class-map | community-list | compressed | control-plane | dot1x | extcommunity-list | interface | lacp | line | lldp | logging | monitor | ospf | ospfv3 | policy-map | prefix-list | qos-map | radius-server | route-map | sflow | snmp | spanning-tree | support-assist | system-qos | trust-map | users | vlt]
Parameters
  • aaa — (Optional) Current candidate AAA configuration.
  • access-list — (Optional) Current candidate access-list configuration.
  • as-path — (Optional) Current candidate as-path configuration.
  • bgp — (Optional) Current candidate BGP configuration.
  • class-map — (Optional) Current candidate class-map configuration.
  • community-list — (Optional) Current candidate community-list configuration.
  • compressed — (Optional) Current candidate configuration in compressed format.
  • control-plane — (Optional) Current candidate control-plane configuration.
  • dot1x — (Optional) Current candidate dot1x configuration.
  • extcommunity-list — (Optional) Current candidate extcommunity-list configuration.
  • interface — (Optional) Current candidate interface configuration.
  • lacp — (Optional) Current candidate LACP configuration.
  • lldp — (Optional) Current candidate LLDP configuration.
  • logging — (Optional) Current candidate logging configuration.
  • monitor — (Optional) Current candidate monitor session configuration.
  • ospf — (Optional) Current candidate OSPF configuration.
  • ospfv3 — (Optional) Current candidate OSPFv3 configuration.
  • policy-map — (Optional) Current candidate policy-map configuration.
  • prefix-list — (Optional) Current candidate prefix-list configuration.
  • qos-map — (Optional) Current candidate qos-map configuration.
  • radius-server — (Optional) Current candidate RADIUS server configuration.
  • route-map — (Optional) Current candidate route-map configuration.
  • sflow — (Optional) Current candidate sFlow configuration.
  • snmp — (Optional) Current candidate SNMP configuration.
  • spanning-tree — (Optional) Current candidate spanning-tree configuration.
  • support-assist — (Optional) Current candidate support-assist configuration.
  • system-qos — (Optional) Current candidate system-qos configuration.
  • trust-map — (Optional) Current candidate trust-map configuration.
  • users — (Optional) Current candidate users configuration.
  • vlt — (Optional) Current candidate VLT domain configuration.
Default
Not configured
Command Mode
EXEC
Usage Information
None
Example
OS10# show candidate-configuration
                                       ! Version 10.2.9999E
                                       ! Last configuration change at Apr  11 10:36:43 2017
                                       !
                                       username admin password $6$q9QBeYjZ$jfxzVqGhkxX3smxJSH9DDz7/3OJc6m5wjF8nnLD7/VKx8SloIhp4NoGZs0I/UNwh8WVuxwfd9q4pWIgNs5BKH.
                                       aaa authentication local
                                       snmp-server contact http://www.dell.com/support
                                       snmp-server location "United States"
                                       logging monitor disable
                                       ip route 0.0.0.0/0 10.11.58.1
                                       !
                                       interface ethernet1/1/1
                                       switchport access vlan 1
                                       no shutdown
                                       !
                                       interface ethernet1/1/2
                                       switchport access vlan 1
                                       no shutdown
                                       !
                                       interface ethernet1/1/3
                                       switchport access vlan 1
                                       no shutdown
                                       !
                                       interface ethernet1/1/4
                                       switchport access vlan 1
                                       no shutdown
                                       !
                                       interface ethernet1/1/5
                                       switchport access vlan 1
                                       no shutdown
                                       !
                                       --more--
                                    
Example (compressed)
OS10# show candidate-configuration compressed
                                       username admin password $6$q9QBeYjZ$jfxzVqGhkxX3smxJSH9DDz7/3OJc6m5wjF8nnLD7/VKx8SloIhp4NoGZs0I/UNwh8WVuxwfd9q4pWIgNs5BKH.
                                       aaa authentication local
                                       snmp-server contact http://www.dell.com/support
                                       snmp-server location "United States"
                                       logging monitor disable
                                       ip route 0.0.0.0/0 10.11.58.1
                                       !
                                       interface range ethernet 1/1/1-1/1/32
                                       switchport access vlan 1
                                       no shutdown
                                       !
                                       interface vlan 1
                                       no shutdown
                                       !
                                       interface mgmt1/1/1
                                       ip address 10.11.58.145/8
                                       no shutdown
                                       ipv6 enable
                                       ipv6 address autoconfig
                                       
                                       !
                                       support-assist
                                       !
                                       policy-map type application policy-iscsi
                                       !
                                       class-map type application class-iscsi
                                       !
                                       class-map type qos class-trust
                                    
Supported Releases
10.2.0E or later

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\