Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC SmartFabric OS10 User Guide Release 10.5.1

PDF

Peer templates

To configure multiple BGP neighbors at one time, create and populate a BGP peer template. An advantage of configuring peer templates is that members of a peer template inherit the configuration properties of the template and share the update policy. Always create a peer template and assign a name to it before adding members to the peer template. Create a peer template before configuring any route policies for the template.

  1. Enable BGP, and assign the AS number to the local BGP speaker in CONFIGURATION mode, from 1 to 65535 for 2 bytes, 1 to 4294967295 | 0.1 to 65535.65535 for 4 bytes, or 0.1 to 65535.65535, in dotted format.
    router bgp as-number
  2. Create a peer template by assigning a neighborhood name to it in ROUTER-BGP mode.
    template template-name
  3. (Optional) Add a text description for the template in ROUTER-TEMPLATE mode.
    description text
  4. Enter Address Family mode in ROUTER-NEIGHBOR mode.
    address-family {[ipv4 | ipv6] [unicast]}
  5. Filter networks in routing updates, create a route-map, and assign a filtering criteria in ROUTER-BGP-NEIGHBOR-AF mode.
    distribute-list prefix-list-name {in | out}
    route-map map-name {in | out}
  6. Add a neighbor as a remote AS in ROUTER-TEMPLATE mode, from 1 to 65535 for 2 bytes, 1 to 4294967295 | 0.1 to 65535.65535 for 4 byte, or 0.1 to 65535.65535, in dotted format.
    neighbor ip-address
  7. (Optional) Add a remote neighbor, and enter the AS number in ROUTER-TEMPLATE mode.
    remote-as as-number
    • To add an EBGP neighbor, configure the as-number parameter with a number different from the BGP as-number configured in the router bgp as-number command.
    • To add an IBGP neighbor, configure the as-number parameter with the same BGP as-number configured in the router bgp as-number command.
    NOTE: When you configure an unnumbered interface, do not configure the remote AS number.
  8. Assign a peer-template with a peer-group name from which to inherit to the neighbor in ROUTER-NEIGHBOR mode.
    • For peers with an IP address:
      inherit template template-name
    • For peers with unnumbered interfaces:
      inherit template template-name inherit-type {ebgp | ibgp}
  9. Enable the neighbor in ROUTER-BGP mode.
    no shutdown

A neighbor may keep its configuration after it is added to a peer group if the neighbor configuration is more specific than the peer group and if the neighbor configuration does not affect outgoing updates.

To display the peer-group configuration assigned to a BGP neighbor, use the show ip bgp peer-group peer-group-name command. The show ip bgp neighbor command output does not display peer-group configurations.

The following example shows a sample configuration:

Configure peer templates

OS10# configure terminal
OS10(config)# router bgp 64601
OS10(config-router-bgp-64601)# template leaf_v4
OS10(config-router-template)# description peer_template_1_abcd
OS10(config-router-template)# address-family ipv4 unicast
OS10(config-router-bgp-template-af)# distribute-list leaf_v4_in in
OS10(config-router-bgp-template-af)# distribute-list leaf_v4_out out
OS10(config-router-bgp-template-af)# route-map set_aspath_prepend in
OS10(config-router-bgp-template-af)# exit
OS10(config-router-template)# exit
OS10(config-router-bgp-64601)# neighbor 100.5.1.1
OS10(config-router-neighbor)# inherit template leaf_v4
OS10(config-router-neighbor)# remote-as 64802
OS10(config-router-neighbor)# no shutdown
OS10(config-router-neighbor)# exit
OS10(config-router-bgp-64601)# neighbor 100.6.1.1
OS10(config-router-neighbor)# inherit template leaf_v4
OS10(config-router-neighbor)# remote-as 64802
OS10(config-router-neighbor)# no shutdown

View peer group status

OS10# show ip bgp peer-group leaf_v4
Peer-group leaf_v4, remote AS 0
  BGP version 4
  Minimum time between advertisement runs is 30 seconds
  Description: peer_template_1_abcd 
  For address family:  Unicast
  BGP neighbor is leaf_v4, peer-group external
  Update packing has 4_OCTET_AS support enabled

  Number of peers in this group 2
  Peer-group members:
    100.5.1.1
    100.6.1.1
OS10# show ip bgp peer-group bg1
    Peer-group bg1, remote AS 0
    BGP version 4
    Minimum time between advertisement runs is 30 seconds

    For address family: Unicast
    BGP neighbor is bg1, peer-group external
    Update packing has 4_OCTET_AS support enabled

    Number of peers in this group 2
    Peer-group members:
    40.1.1.2

    ethernet 1/1/1
OS10# show ip bgp peer-group leaf_v4 summary
BGP router identifier 100.0.0.8 local AS number 64601
Neighbor        AS       MsgRcvd     MsgSent     Up/Down        State/Pfx
100.5.1.1       64802    376         325         04:28:25       1251
100.6.1.1       64802    376         327         04:26:17       1251
OS10# show ip bgp peer-group bg1 summary
BGP router identifier 14.233.209.106 local AS number 10
Neighbor           AS       MsgRcvd        MsgSent          Up/Down        State/Pfx
40.1.1.2           20          15             19            00:00:32          0

ethernet 1/1/1     20          15             19            00:00:32          0

View running configuration

OS10# show running-configuration bgp
!
router bgp 64601
 bestpath as-path multipath-relax
 bestpath med missing-as-worst
 non-deterministic-med
 router-id 100.0.0.8
 !
 template leaf_v4
 description peer_template_1_abcd  !
  address-family ipv4 unicast
   distribute-list leaf_v4_in in
   distribute-list leaf_v4_out out
   route-map set_aspath_prepend in
 !
 neighbor 100.5.1.1
  description leaf_connected_ebgp_neighbor
  bfd
  inherit template leaf_v4
  remote-as 64802
  no shutdown
 !
 neighbor 100.6.1.1
  description leaf_connected_ebgp_neighbor
  bfd
  inherit template leaf_v4
  remote-as 64802
  no shutdown
 !

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\