Dell EMC OpenManage Essentials Version 2.5 User's Guide

Upgrading OpenManage Essentials

You can upgrade from OpenManage Essentials version 2.1 and later to OpenManage Essentials version 2.5.

Before you upgrade, ensure that the minimum available free space on the hard drive is about 10 GB.
  • NOTE: OpenManage Essentials 2.5 use TLS version 1.2 to support Feature Usage Settings and the following features of MX7000 chassis—discovery, system update, device configuration template creation and deployment, and remediation. For more information about the best practices to be followed to secure .NET framework applications that use the TLS protocol on the management station, see www.docs.microsoft.com/en-us/dotnet/framework/network-programming/tls.
To upgrade:
  1. Double-click the OpenManage Essentials executable file. The Dell OpenManage Install screen is displayed. The following options are available:
    • Dell EMC OpenManage Essentials — Select this option to install OpenManage Essentials, and Troubleshooting Tool.
    • Dell EMC Repository Manager — Select this option to install Repository Manager. Using Repository Manager, you can create customized bundles and repositories of Update Packages, software utilities such as update drivers, firmware, BIOS, and other applications.
    • Dell EMC License Manager — Select this option to install License Manager. The License Manager is a one-to-many license deployment and reporting tool for the integrated Dell Remote Access Controller (iDRAC), Chassis Management Controller (CMC), OpenManage Essentials, and PowerEdge storage sled licenses.
    • Dell EMC SupportAssist Enterprise — Select this option to install SupportAssist Enterprise. The SupportAssist Enterprise provides proactive support capabilities for supported server, storage, and networking solutions.
      • NOTE: If SupportAssist Enterprise is already installed on the system, by default, the Dell EMC SupportAssist Enterprise option is selected and disabled. After the upgrade of OpenManage Essentials, SupportAssist Enterprise is also upgraded. If applicable, you may be required to provide the proxy settings during the upgrade of SupportAssist Enterprise. For more information, see the Dell EMC SupportAssist User’s Guide at www.dell.com/ServiceabilityTools.
    • Documentation — Click to view the online help.
    • View Readme — Click to view the readme file. To view the latest readme, go to DellTechCenter.com/OME.
  2. In the OpenManage Install screen, select Dell EMC OpenManage Essentials and click Install. The OpenManage Essentials Prerequisites window, displays the following requirement types:
    • Critical — This error condition prevents the installation of a feature.
    • Warning — This warning condition may disable the Typical installation but not an Upgrade of the feature later during installation.
    • Information — This informational condition does not affect the Typical installation of a feature.
    • NOTE: If OpenManage Essentials version 1.1 is installed on the system on a local database using SQL Server 2008 Express edition, and an OpenManage Essentials-specific named instance SQLEXPRESSOME is not available, the SQL Server prerequisites displays a Critical icon. To proceed with the installation, you must install SQL Server Express 2012 SP1 with the SQLEXPRESSOME instance. Data from the earlier version of SQL Server is migrated automatically.
  3. Click Install Essentials.
  4. In the install wizard for OpenManage Essentials, click Next.
  5. In the License Agreement page, read the license agreement, select I accept the terms in the license agreement , and then click Next.
  6. If applicable, provide the Package Server Port and the Task Manager Service Port. If either the package server port or task manager service port is blocked during an upgrade, provide a new port. Click Next.
  7. Click Ok .
  8. Click Install.
  9. After the installation is complete, click Finish. After the upgrade, when you launch OpenManage Essentials version 2.5 for the first time, the Feature Usage Settings window is displayed. To understand and improve the most used features in OpenManage Essentials, few nonsensitive information is collected, and this feature is enabled by default. To disable this feature at a later time, click Settings > Feature Usage Settings , and then clear the I Agree check box.
After the upgrade is complete, you must perform the following actions:
  1. Run discovery and inventory for all existing discovery ranges.
  2. In the Device Search portal, verify if you get the expected results for all existing device queries.
  3. In the System Update portal, if the existing catalog is not the latest, ensure you import the latest catalogs from donwloads.dell.com.

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\