DSA-2020-057: Dell EMC Avamar Server Deserialization of Untrusted Data Vulnerability


alert-notice

Critical

First published:  02 Mar 2020
Last updated:  12 Mar 2020

CVE ID(s)

Overview

Severity Rating (CVSS Base Score)

9.8 (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected products:   
Dell EMC Avamar Server versions 7.4.1, 7.5.0, 7.5.1, 18.1, 18.2, 19.1, and 19.2
Dell EMC Integrated Data Protection Appliance (IDPA) 2.0, 2.1, 2.2, 2.3, 2.4, and 2.4.1


Summary:   
Dell EMC Avamar Server and Dell EMC Integrated Data Protection Appliance contain remediation for a security vulnerability that may be exploited by malicious users to compromise the affected system.

Details

Filled_Alert_Notice_Symbol   Severity Disclaimer

For an explanation of Severity Ratings, refer to Dell EMC Knowledgebase article 468307. Dell EMC recommends all customers take into account both the base score and any relevant temporal and environmental scores which may impact the potential severity associated with particular security vulnerability.

Read and use the information in this Dell EMC Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this product alert, contact Dell EMC Software Technical Support at 1-877-534-2867. Dell EMC distributes Dell EMC Security Advisories, in order to bring to the attention of users of the affected Dell EMC products, important security information. Dell EMC recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. Dell EMC disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event, shall Dell EMC or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Dell EMC or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.

Recommendations

The following Dell EMC Avamar releases contain a resolution to this vulnerability:

  • Dell EMC Avamar Server 7.4.1 – HOTFIX 316625

  • Dell EMC Avamar Server 7.5.0 – HOTFIX 316626

  • Dell EMC Avamar Server 7.5.1 – HOTFIX 316627

  • Dell EMC Avamar Server 18.2  – HOTFIX 316484

  • Dell EMC Avamar Server 19.1  – HOTFIX 316485

  • Dell EMC Avamar Server 19.2  – HOTFIX 316691

  • Dell EMC Integrated Data Protection Appliance (IDPA) 2.0 – HOTFIX 316625

  • Dell EMC Integrated Data Protection Appliance (IDPA) 2.1 – HOTFIX 316626

  • Dell EMC Integrated Data Protection Appliance (IDPA) 2.2 – HOTFIX 316627

  • Dell EMC Integrated Data Protection Appliance (IDPA) 2.3 – HOTFIX 316484

  • Dell EMC Integrated Data Protection Appliance (IDPA) 2.4 – HOTFIX 316484

  • Dell EMC Integrated Data Protection Appliance (IDPA) 2.4.1 – HOTFIX 316484

For other affected versions, Dell EMC recommends scheduling an upgrade of the Avamar server to the most recent service pack for the release and applying the appropriate hotfix.

For affected IDPA releases, install the appropriate hotfix on the Avamar server directly.

Dell EMC recommends all customers apply the hotfix at the earliest opportunity. Refer to KB Article 513978: How to install an Avamar .avp hotfix using Avamar Installer (AVI) for instructions on applying the hotfix.

Note: Applying the hotfix will restart the Management Console Service (MCS). It is recommended to schedule this activity.

Credit

Dell EMC would like to thank An Trinh for reporting this vulnerability.

Read and use the information in this Dell EMC Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this product alert, contact Dell EMC Software Technical Support at 1-877-534-2867. Dell EMC distributes Dell EMC Security Advisories, in order to bring to the attention of users of the affected Dell EMC products, important security information. Dell EMC recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. Dell EMC disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event, shall Dell EMC or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Dell EMC or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.