DSA-2020-208: Dell EMC ECS Security Update for an Exposure of Resource vulnerability


alert-notice

High

First published:  18 Aug 2020
Last updated:  18 Aug 2020

CVE ID(s)

Overview

Severity Rating (CVSS Base Score)

Summary: 
Dell EMC ECS contains remediation for an Exposure of Resource Vulnerability that could be exploited by malicious users to compromise the affected system.

Details

Filled_Alert_Notice_Symbol   Severity Disclaimer

For an explanation of Severity Ratings, refer to Dell EMC Knowledgebase article 468307. Dell EMC recommends all customers take into account both the base score and any relevant temporal and environmental scores which may impact the potential severity associated with particular security vulnerability.

Read and use the information in this Dell EMC Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this product alert, contact Dell EMC Software Technical Support at 1-877-534-2867. Dell EMC distributes Dell EMC Security Advisories, in order to bring to the attention of users of the affected Dell EMC products, important security information. Dell EMC recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. Dell EMC disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event, shall Dell EMC or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Dell EMC or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.

Recommendations

Affected products: 
ECS versions prior to v3.5

Remediation:
The following ECS releases contain resolutions to these vulnerabilities:
  • Dell EMC ECS v3.5 and above

Dell EMC recommends all customers upgrade at the earliest opportunity to the latest ECS 3.5.x.x code version. 

NOTE: Customers should open an “Operating Environment Upgrade” Service Request with the ECS Remote Proactive team using the following link: https://www.dell.com/support/home

Read and use the information in this Dell EMC Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this product alert, contact Dell EMC Software Technical Support at 1-877-534-2867. Dell EMC distributes Dell EMC Security Advisories, in order to bring to the attention of users of the affected Dell EMC products, important security information. Dell EMC recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. Dell EMC disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event, shall Dell EMC or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Dell EMC or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.