Alienware Desktops

2 Bronze

Aurora R12, no display after cleaning inside

Recently I have opened my Aurora R12 Alienware for maintenance. Unplugged some power supply cables just to blow out some dust. After that, there was no display at all, also no power supply for the keyboard or mouse, both USB.

I have performed the removal of the coin battery and also changed the pswd connector to the CMOS CLR for 10 to 20 seconds, as was suggested on different documentation.

None of the mentioned above worked. I can't see the Alienware logo, nor can enter the BIOS nor Windows.

Update = Resolved- After completing troubleshooting, a DELL-Cares agent setup a parts replacement.

Replies (15)
6 Indium

If the system worked fine before you opened it up and does not now, then something has changed. Either a cable is loose or not plugged in at all. Or possibly plugged in incorrectly. Go back and check each connection carefully including any cable or connection you may have inadvertently unplugged or loosened. Unplug and plug back in every connection just to double check your connections.




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with MSI B-450M Pro-VDH Max budget build with an Athlon 3000G
Real work on a Latitude E5430

I have plugged the 4 motherboard cables, red, white, blue, and black into the power supply. Also, I have no Hard Drive, just the M.2, so the white cables were unplugged from the beginning. The GPU is properly connected to the power supply, It lights up properly.

Does anyone knows why Dell doesn't offer any support on this cases? It was an expensive computer I'm only getting support from the community... 

2 Bronze

Are you connecting to your display with HDMI?  If so, did you accidentally connect the HDMI cable to the board HDMI port instead of the GPU HDMI port?

The motherboard doesn't have an HDMI, just the GPU does. This is why I can't tell if the motherboard is not recognizing the GPU, in which case I won't be able to get video display to run windows or get into the bios. 

5 Tungsten

Double check all power connectors, especially the 8 PIN EPS connector.

 

That's why it is always a good idea to take a few pictures of the board before you begin, so you can go by that to see if all cables are plugged in correctly.

So far, the motherboard has all the power connectors well placed. The GPU is well connected and it lights up so it does receive power correctly.

I read there are many situations where the bios has a failure and can't get any video and DELL sends a new motherboard as a warranty. How can I get in touch with Dell to ask for a replacement?

I have tested another PSU, and also a different GPU with no luck. So it has to be the motherboard, I guess the BIOS specifically, and since this board doesn't have any HDMI outputs I can't get any video at all. 

Re: How can I get in touch with Dell to ask for a replacement?

Use online Dell chat.

Re: Aurora r12

R12 mobo has got rid of the proprietary black 8 pin GPU_PWR socket previously seen on R9 or older Aurora (R8/7/6/5) mobo.  R11/10 does not have the black 8 pin socket either.  Good riddance.

redxps630_0-1638740966620.jpeg

 


It's a white one now, 8 pin EPS at the top of the board.

Top Contributor
Latest Solutions