Alienware Desktops

Last reply by 12-10-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
193

Aurora R7, RX 6750 XT upgrade issues

Assistance needed. Just installed a new RX 6750 XT into my Aurora R7. No issues with fitting it in there just a bit larger than the 1080 Ti that I ordered with the computer. I do not have any power issues since the R7 came with a 850w PSU. I have tried to get the computer to boot up several time now, but it will not leave the Alienware splash screen. I have tried to go into the bios from this location but every time I select F2 the computer just sits there. I have swapped back to the old 1080 card and have no issues with boot up into windows. I can even get into the bios with the old video card. I have the most current bios firmware load on the computer 1.0.26. Any suggestions or help would be greatly appreciated. Thanks.

Replies (2)
7 Gold
190

Dell bios has a hard time approving the firmware of new amd gpu based on its current settings.

try use old gpu to enter bios, disable secure boot in bios.  If it is already off, try turn it on.  save changes then exit.

if still no luck, replace cmos battery with a new battery and clear cmos settings via motherboard jumper.

there is a slight possibility that the 6750 xt you had has issue if after all you still get stuck in post which is when Alienhead stuck on screen.  6750 xt should be c/w R7 as a very close model 6700 xt is validated in R7.  https://www.userbenchmark.com/UserRun/57058579

 


166

Thanks for the assist.

Latest Solutions
Top Contributor