Dell OpenManage Essentials

2 Bronze

OpenManage Essentials not showing hard drive information for ESXi 5.0 systems.

I have some servers running ESXi 5.0 with Dell OpenManage 6.5 for esxi500 installed.  When I point the OpenManage Server Administrator at them everything shows just fine.  I can drill down to the individual drives and see and do just about anything I would want to.  I wanted something where I could set up to react to alerts etc from multiple machines.  OpenManage Essentials looked like the answer.  It installed ok and when I pointed it at an ESXi box it discovered it and pulled all of it's information except the hard drive information.

Am I missing something to get the hard drive information to show?

Also, when it first discovered the box it showed it with the green check box.  It looks like after it rescans the system it changes the heath status to the grey diamond with a question mark.  There are no alerts.  The hardware logs just says Could not connect to device to obtain logs.  I can remove the system and re-discover it and everything populates and goes green again but the hardware logs stay the same.

Any hints would be great.

Replies (18)
5 Tungsten

Hi and thanks for the post.

Can you double check that you did the steps we list out in the ESXi setup whitepaper?

Have you done the SNMP configuration steps on ESXi to direct the alerts to the OME server (step 4)?

Thanks,

Rob

en.community.dell.com/.../19446745.aspx

DELL-Rob C
Social Media Support
#IWork4Dell

5 Tungsten

also...

OMSA VIB 7.0 not 6.5 should be installed

ESXi 5 build version should be greater than 504890

Rob

DELL-Rob C
Social Media Support
#IWork4Dell

2 Bronze

If you are referring to: en.community.dell.com/.../20071085.aspx

I had the snmp enabled but I did not have the traps turned on.  I turned them on.  I am getting alerts from the esxi box now but the hard drive information is still not populating.

Interestingly enough, the hardware logs are showing up now as well.  Does this mean OME makes the esxi box send the logs via traps?  I know the OMSA didn't because it worked without snmp turned on the esxi box at all.  Maybe something just worked loose with all the playing with it I have been doing.

Still need the hard drive information though.

2 Bronze

Where would you get that build?  I can only get build 469512 from the vmware site.  Also, why would the OMSA VIB 6.5 work with the OMSA and not OME?  I will go look for the VIB 7.0 but bringing down a server with a bunch of virtuals on it is not the best solution.  That will take time and planning and notification of all the affected people etc....

5 Tungsten

H/W logs from the link on the right side of the device tree?  Yeah, those are pulled real-time via SNMP when you click on them.

DELL-Rob C
Social Media Support
#IWork4Dell

5 Tungsten

 

6.5 had issues that were fixed in 7.

See if that helps.

DELL-Rob C
Social Media Support
#IWork4Dell

2 Bronze

Ok, I switched to playing with a test server that is not in production and I never really needed monitoring on.  It was setup with the same ESXi and OMSA.  I could connect to it using a linux box with OMSA on it like I could to the other box.  It worked fine.

Next I put the esxi update1 in and restarted.  It came up showing build 623860.  I could still connect using the OMSA linux server and see everything.  OME didn't change.  Still no hard drive information.

I then updated the OMSA on ESXi to 7.0.  I now cannot connect to the ESXi server using the OMSA linux box.  OME gets even less information than it did before.  I removed the OpenManage 7.0 vib and put the 6.5 back in and it all came back to where it was.  I put 7.0 back in and it broke again.  Doing a yum update on the linux box does not update anything from the dell open manage repo so I don't think there are any updates for that.  Looks like 7.0 does not work.

I am not physically at the location so I cannot use the cd you pointed to above to update drivers etc...

2 Bronze

I guess it just comes down to, why can't OME see the same things OMSA can when they use the same agent?  OMSA can see the drives with or without snmp on.  They both use WS-Man so they should both be able to get the same info and they do except for the hard drives.  I can see how having the snmp traps would be useful to get immediate failures but I am just interested in having OME go look at the inventory every so often and tell me if a drive has failed.  I would be ok with getting snmp traps, which OME is receiving from esxi, but it doesn't do any good if it doesn't know about the drives.

DellEMC

Hi,

Thanks for the updates. OME currently talks to VMWare ESXi provider using WS-MAN to get the hardware inventory and it also talks to OMSA using WS-MAN to get the hardware health. OME also receives SNMP traps from ESXi host.

If you want to monitor for hard drive failures, you can send SNMP traps from ESXi host to OME which should generate a trap on hard drive failure. You can also monitor overall system health from OME using WS-MAN which should change from normal on hard drive failure.

OMSA 7.0 VIB may not be supporting ESXi 5 update 1 yet. It would be good to open a support ticket and they can investigate if there are any specific issues. Here is the number 800-945-3355

Regards

Abhijit

Top Contributor
Latest Solutions