Enterprise Client

2 Bronze

BSOD when installing XP on AF HDD - Aligned correctly

Hi, I hope you can help me out with this one, or give me some ideas 'cause Im running out of them...

In April I ordered and received an AF HDD to prepare our OS deployment enviroment for these new drives. We're running MDT2010 with SCCM 2007.
I got the Seagate Momentus Thin ST320LT007 (320GB), plugged it in to a E6320.

First, I just tried to install it w/ making any changes, which of course failed because of the misalignment (got a BSOD in the XP setup)
I updated our WinPE3.0 boot image with 982018 (update 3), made sure I hade the latest RST Storage Drivers and everything worked out just fine. I've verified with DellAFDT.exe that the disk partition is aligned.

But now when we've started to get our new Latitudes (E6420/E6320) with the AF disks, I got the BSOD back again (for XP). The disk is now: Seagate Momentus Thin ST250LT007 (250GB). I replaced it with the previous 320LT drive and that one worked. (same E6320 chassi, just to verify)

Now, I checked again with DellAFDT.exe and the 250LT is aligned and is recognized as Advanced Format. I went back to my old WinPE3.0, unpatched, tried again and that one came out as misaligned (duh..). Now I dont get a BSOD but do get poor preformance.

BSOD reads Unmountable Boot Volume, and it shows up after the Task Sequence has booted up in XP the second time after been installing the drivers and joining the domain.
BIOS settings is set to default (RAID), current version A05.

I appreciate any help!

Replies (10)
4 Beryllium

Since you are testing against the same chassis, I'll assume that you don't have an issue with the Intel RST being injected properly. Also, since you can build with the 320LT, you probably are not using "ExtendOEMpartition=1" in your sysprep.inf.

Can you give the BSOD error code that is provided with the "Unmountable Boot Volume" message?
2 Bronze

Yes, correct. I Also tried with the latest intel RST drivers from their download page, but no luck. No "ExtendOEMpartition=1" in my sysprep.inf

The error code reads:
0x000000ED (0x8A5E8680, 0xC000014F, 0x00000000, 0x00000000)

Now, I have to build a new XP image anyway - so I will test and see if the result will come out different with that one. But I think its very strange that it works with the 320LT drive but not with the 250LT.

2 Bronze

<Profanity removed>
Of course it was the "ExtendOEMpartition=1" in sysprep.inf - I got all my config packages mixed up. Also the fact that the 320LT disk actually worked, got me confused.

Thanks for all your help in this forum, Warren - and please forget about this thread

Best regards,

4 Beryllium

Glad to hear that you got it sorted out. This is a great thread as the "ExtendOEMPartition=1" seems to be tripping up lots of people.
3 Silver

@Warren - This is ArmitageID here from the old Dell TechCenter side. My first post in the new system so not sure how my name will come across. In any case, I am having this SAME issue with many of our international machines. I received the 320GB kit and everything is working fine. These new machines in Oman have the 250GB version and are running into the BSOD. The error message is:


STOP: 0x000000ED  (0x8A3D2C08, 0XC000014F, 0X00000000, 0X00000000)

I haven't looked for the ExtendOEMpartition=1 int he sysprep.inf file yet, I'll take a look.

My biggest question is why it works fine with the 320GB unit that was sent???

3 Silver

*Update 1* I checked my sysprep.inf file and it is there "ExtendOEMpartition=1". The Unattend.txt file has it in there as well, but it is commented out. Any advice?

4 Beryllium

The general guidance is to not use "ExtendOEMPartition=1" so I would suggest removing that from your Sysprep.inf to see if that addresses it.  I don't have any ideas as to why the 320GB worked and the 250GB didn't.

3 Silver

@Warren If I change that variable then will it no longer be able to apply the OS to the entire disk? I format and partition the drive during imaging so I assume the entire disk would be available for use. I assume the solution is to set ExtendOEMPartition=0? I guess my question is does this variable even come into play when applying a WIM with MDT or is this more for people who use something like ghost?

I guess the root question I'm trying to ask here is if the image was built on a machine with a 40GB hard drive, setting ExtendOEMPartition=0 won't result in 280GB of the drive being on partitioned. I don't want to have to manually expand the drive latter down the road. Just looking for some clarification.

Thank you.

4 Beryllium

If you are formatting and partitioning the drive then the ExtendOEMPartition option isn't needed at all.  I've never used it and from what I hear from other customers, it's just a roadblock for AFHDD's.  Give it a try without it and let me know if you see anything detrimental to that configuration.

Top Contributor
Latest Solutions