EqualLogic

Last reply by 10-25-2013 Solved
Start a Discussion
2 Bronze
2 Bronze
46771

Getting EqualLogic to work with Ovirt

If anyone is having issues getting Ovirt to work with EqualLogic the following link may be helpful:

https://sites.google.com/a/keele.ac.uk/partlycloudy/ovirt/gettingovirttoworkwithdellequallogic

Ovirt is a very good free alternative to a lot of commercial vm management solutions.

Solution (1)

Accepted Solutions
Anonymous
Not applicable
1427

One thing to change is the path_checker in /etc/multipath.conf.   There is a bug in Multipathd, that shows itself with the EQL 7.0 firmware, since that's 4K sector capable.  When using readsector0 it causes a protocol error right after login.  Change readsector0 to 'tur' or 'directio'

This is what I typically use for EQL in /etc/multipath.conf

defaults {

       udev_dir                /dev

       polling_interval        10

       path_selector           "round-robin 0"

       path_grouping_policy    multibus

       getuid_callout          "/lib/udev/scsi_id --whitelisted --device=/dev/%n"

       path_checker            tur

       rr_min_io               10

       max_fds                 8192

       rr_weight               priorities

       failback                immediate

       no_path_retry           fail

       user_friendly_names     yes

}

Also make sure that the interface file has both iSCSI_ifacename and net_ifacename

cat /var/lib/iscsi/ifaces/eth0

# BEGIN RECORD 6.2.0-873.2.el6

iface.iscsi_ifacename = eth0

iface.net_ifacename = eth0

iface.transport_name = tcp

iface.vlan_id = 0

iface.vlan_priority = 0

iface.iface_num = 0

iface.mtu = 0

iface.port = 0

# END RECORD

A couple of common tweaks to /etc/iscsid/iscsid.conf

################################

# session and device queue depth

################################

# To control how many commands the session will queue set

# node.session.cmds_max to an integer between 2 and 2048 that is also

# a power of 2. The default is 128.

node.session.cmds_max = 1024

# To control the device's queue depth set node.session.queue_depth

# to a value between 1 and 1024. The default is 32.

node.session.queue_depth = 128

node.session.iscsi.FastAbort = No

Regards,

View solution in original post

Replies (2)
Moderator
Moderator
1427

First, the multipathing solution tested by EqualLogic is only RHEL and SUSE Linux.

However, at first glance, the multipath.conf file doesn't seem to be complete (I really didn't review all the files).

Missing is:

getuid_callout "/sbin/scsi_id -g -u /dev/%n"

Add the wwid for the devices to the multipath section, and an alias (in the example, replace your actual wwid with your device):

       multipath {

               wwid                    12345123451234515b521249fae00

               alias                   eql-rhel6

       }

}

There may be other misconfigurations, we have a document on setting up RHEL at the eqlsupport.dell.com (support contract required to login), that you can review and modify for your needs.

-joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell 

Anonymous
Not applicable
1428

One thing to change is the path_checker in /etc/multipath.conf.   There is a bug in Multipathd, that shows itself with the EQL 7.0 firmware, since that's 4K sector capable.  When using readsector0 it causes a protocol error right after login.  Change readsector0 to 'tur' or 'directio'

This is what I typically use for EQL in /etc/multipath.conf

defaults {

       udev_dir                /dev

       polling_interval        10

       path_selector           "round-robin 0"

       path_grouping_policy    multibus

       getuid_callout          "/lib/udev/scsi_id --whitelisted --device=/dev/%n"

       path_checker            tur

       rr_min_io               10

       max_fds                 8192

       rr_weight               priorities

       failback                immediate

       no_path_retry           fail

       user_friendly_names     yes

}

Also make sure that the interface file has both iSCSI_ifacename and net_ifacename

cat /var/lib/iscsi/ifaces/eth0

# BEGIN RECORD 6.2.0-873.2.el6

iface.iscsi_ifacename = eth0

iface.net_ifacename = eth0

iface.transport_name = tcp

iface.vlan_id = 0

iface.vlan_priority = 0

iface.iface_num = 0

iface.mtu = 0

iface.port = 0

# END RECORD

A couple of common tweaks to /etc/iscsid/iscsid.conf

################################

# session and device queue depth

################################

# To control how many commands the session will queue set

# node.session.cmds_max to an integer between 2 and 2048 that is also

# a power of 2. The default is 128.

node.session.cmds_max = 1024

# To control the device's queue depth set node.session.queue_depth

# to a value between 1 and 1024. The default is 32.

node.session.queue_depth = 128

node.session.iscsi.FastAbort = No

Regards,

Latest Solutions
Top Contributor