Inspiron

Last reply by 10-06-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
2005

G15 5515 Game-Shift Does not Work

Dell G15 5515 Ryzen Edition

After a windows 11 update and an update to Alienware command center in May or so, my game shift has stopped working entirely. I decided to uninstall Alienware Command Center entirely according to the Dell guide, along with OC Controls application. I reinstalled it and it did nothing. I tried the package manager, I tried repairing the app. I tried updating it from Microsoft Store.

Literally nothing I have tried seems to have worked. I can no longer do a system restore and cannot use game shift. It simply does not turn on. The icon does not show up on the command center at all and the temperature limit does not increase.

Apart from that, my power management is broken as well. The moment I click on the "New Profile" button, the app crashes immediately.

Would love to get some good guidance on this as game shift would help me a lot. Thank you.

Replies (7)
2 Bronze
2 Bronze
1925

Yes, Same issue. Since i have updated to Windows 11.
Tried so many things, nothing works.

2 Bronze
2 Bronze
1824

Same exact problem with my G7... I've been trying to find a solution all over the internet. Game-shift option no longer available on Alienware, and therefore the G-Shift button, and the coinciding fn+G command do not work.

5 Rhenium
1751

You have Game Shift feature even without G-key on F9! In order to work you have to install first Alienware Command Center Application and then Alienware OC Controls Application. Pressing F9 or FN+F9, depending on your BIOS settings, will launch G-mode!

 
1690

It's a software issue. The laptop simply does not go into Game Shift no matter what method I use to do so.

2 Bronze
2 Bronze
1680

I also have this problem on a G15 5515 that is brand new. I thought it was because I was on battery power at first, but even after plugging in my charger nothing changed. 

1484

i had this issue. I opened the alienware command center, then settings, then profiles, then turned OFF the auto profile. Game shift has worked fine since

2 Bronze
2 Bronze
1253

I had this problem on my brand new laptop. Found out what the issue is. Hit the windows key and type in setting. Go to gaming. Go to game mode. Turn off game mode which is on by default.

It appears game mode will block certain background tasks to prevent lag or things of that nature but my guess is that it is also blocking the alien command center which isn't allowing you to hit G button to turn on high performance mode. Stupid little bug but I realized this once I went into the Alien Command Center and then hit G mode it would work but it had to be open...not very convenient. With game mode turned off it works just fine. Hope that helps.

Latest Solutions
Top Contributor