Inspiron

Last reply by 07-01-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
13187

G5 5587, slow performance on battery

My dell G5 is almost not usable on battery. Not able to play movies, songs over Bluetooth speakers, etc properly. I have already selected "High Performance" settings on battery in Power Plan but still, CPU gets slow to 798Hz from 3989Hz. Please help me out of this. I have also tried to change the processor power management in advance power settings on the battery to 100% percent but still, CPU is running very slow, sometimes reaches to 2GHz but most of the time it stays on 798Hz.

Labels (2)
Replies (17)
Moderator
Moderator
12438

ss_123,

 

Click the link here for troubleshooting and resolving slow performance. Also, click here to update your system bios to the latest version if you have not done so. You may also try uninstalling smartbyte from the computer as well.

 

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

12390

These are the random solution dell people give whoever raises slow CPU problem. I have seen other threads also regarding this in Reddit and Dell Community. No concrete solution to this problem. Slowing down the CPU during on battery should be as per user preference not by the laptop manufacturer. Consult with your engineers regarding this issue and come up with a fix. Other threads regarding this. https://www.dell.com/community/Inspiron/Dell-G7-CPU-stuck-at-0-8-GHz-on-Battery/td-p/6111521 https://www.reddit.com/r/Dell/comments/9bmyem/slow_cpu_on_battery/
12388

SS_123,

 

I will contact the engineer for information about slow performance.

 

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

12098

We are still waiting for a fix from Dell ...

5 Tungsten
12092

In GeForce Experience go to the Settings menu then choose Games from the left side.

 

There should be an option called Battery Boost that allows you to set your maximum framerate.  Have you tried turning this off or upping the max framerate?

 

 

Regards,

Adrian

2 Bronze
2 Bronze
11991

hey! i finally figured it out!!! After a year or two of being very frustrated and needing to carry my power adapter everywhere. 

Go into your BIOS settings and turn off intel speed shift and intel speed step!!! 

9624

Check Inte Graphic Driver. Try uninstall all Inte Graphic Driver and instal other version.

9372

@juscheng You are the real MVP!!

I just wasted 3 hours with the incompetent Dell Support via ticket <Service request number removed>

The tech rep spent a long time trying to tell me that it was a normal behavior, he changed some battery settings in windows and said that I should test it for around 10 days to decide If the problem was still there.

I told him that i was 100% sure the problem was still there and that he was just trying to hang up my call so that in 10 days someone else took the ticket. He said the only solution is to reinstall windows, I was like OK lets go, I am going to do a backup and show you that a reinstall doesn't fix it.

While waiting for the backup I decided to do some last minute google and found your solution!!

Also, I am still waiting to the email that he was going to send so that I could reply and notify when I was ready to do the fresh install.

I am so glad I decided to do one final google search!

And Dell you really need to monitor your tech reps, he was completely denying that I had an issue because the Scan that is executed via support assist said that everything was OK! What a waste of time and patience!!

Adding for google searches:

Dell G5 5587 unusable via battery

Dell G5 5587 really slow on battery

Dell G5 5587 battery problem

2 Bronze
2 Bronze
2832

From Bios, disable Intel shift. Keep intel step on so that your CPU can use the Boost mode as well as you can play around with the CPU power via the DELL Power app (Thermal management)

Latest Solutions
Top Contributor