Inspiron

Last reply by 11-26-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
254

could the I/O-board power cable connection problem cause "AC adaptor not installed"

Inspiron 15 3511

I got this computer about a year ago and barely used it.  Recently noticed that it kept power off whenever I move it a bit.  It turns out that the battery is not recognized.  I tried to follow some tips here and managed to have the battery shows up, but it will not charge.  Following more tips to find out that the AC adaptor is shown as not installed in the BIOS.  I even tried to download the BIOS update but still cannot install due to battery at 0.

While I was looking into the issue and opened up the back of the laptop, I noticed that a cable seems to be loose.  Some google later I can identify it is the power cable of the I/O-board.  There is a latch that should be able to secure the cable in place, but this one does not lock in place(I have confirmed that another cable does lock in place).  Could it be the reason for my problem?

Also noticed that in Device Manger there is an "System Firmware 1.19.0 that has a warning mark.  I assume that is the BIOS update that can not install due to no battery?

 

Please help!  What I should do?  should I go buy a new I/O-board, and will that solve all my problem?  Thanks

Solution (1)

Accepted Solutions
8 Krypton
246

If two AC adapters are showing unknown, the DC power jack is the likely issue.

The system will not flash a BIOS (nor should you) with an unrecognized AC adapter.

 

View solution in original post

Replies (3)
2 Bronze
2 Bronze
251

BTW the model is 3501, not 3511.

8 Krypton
247

If two AC adapters are showing unknown, the DC power jack is the likely issue.

The system will not flash a BIOS (nor should you) with an unrecognized AC adapter.

 

238

I could not believe the answer is so simple!  I had another dell computer so I just used the other adapter and, it’s charging!

I think I have been refusing to believe the adapter is the problem because it is barely a year and there’s nothing visible damage to it.  
Guess I need to buy a new adapter for solution!

Latest Solutions
Top Contributor